WordPress.org

Ready to get started?Download WordPress

Forums

templates, index and apache error? (5 posts)

  1. TydesPerdition
    Member
    Posted 8 years ago #

    I was trying to edit my index file to include an author template. Now I'm getting this error:

    Warning: main(/usr/local/psa/home/vhosts/distillusions.com/httpdocs/test/wp-content/themes/fluidity3c/index.php): failed to open stream: Permission denied in /usr/local/psa/home/vhosts/distillusions.com/httpdocs/test/wp-includes/template-loader.php on line 17

    Warning: main(): Failed opening '/usr/local/psa/home/vhosts/distillusions.com/httpdocs/test/wp-content/themes/fluidity3c/index.php' for inclusion (include_path='.:/usr/local/psa/apache/share/pear:.:.') in /usr/local/psa/home/vhosts/distillusions.com/httpdocs/test/wp-includes/template-loader.php on line 17

    I see the word 'apache' in there and that scares the shit out of me. What did I do? I've re-uploaded the old files for the index.php and template-loader.php (just for good measure even though I never touched it) but I'm still seeing this error.

  2. moshu
    Member
    Posted 8 years ago #

    You will have to a bit more specific about what you are trying to do: how exactly are you "including" the author template in an index? What is the filename? Why author template inside the index?

  3. TydesPerdition
    Member
    Posted 8 years ago #

    In the index file (index.php) of the theme that I'm trying to customize, it already had a section to include <?php _e('Author'); ?> (it was disabled by default) and upon changing that to include it and uploading it, things got all screwed up and the theme no longer works, giving me the above message. Other templates work fine though. I've re-uploaded the original files, but it doesn't do jack.

  4. moshu
    Member
    Posted 8 years ago #

    <?php _e('Author'); ?> <== this one is not supposed to include anything. It will just display the word "Author". Nothing else.

  5. TydesPerdition
    Member
    Posted 8 years ago #

    Ok. That's bizarre then. This is the only thing that I've done to this theme and now it doesn't work. Time to delete the whole folder and start over maybe.

Topic Closed

This topic has been closed to new replies.

About this Topic