WordPress.org

Ready to get started?Download WordPress

Forums

Template Trouble (6 posts)

  1. sdj entertainment
    Member
    Posted 5 years ago #

    Hey There,
    I have been experimenting with using templates to make different pages throughout my website to look different from one another. I have two different pages. A Home page which uses a template page of "home" and a Recent work page which uses a template page of "recentwork". I have tripled check everything and can't see anything wrong with the code and yes the template name code is correct too. However both pages reference the "home" template page. I was wondering if anybody out there has come across this problem or have any suggestions. Anything would help.
    Cheers,
    Simon Jones

  2. Jabbok
    Member
    Posted 5 years ago #

    Are you selecting the "recentwork" template when you create the page you want to use? There is an option for selecting the template you want to use for each page.

  3. Samuel B
    moderator
    Posted 5 years ago #

  4. sdj entertainment
    Member
    Posted 5 years ago #

    Thanks for the quick replies, In answer to Jabbok, yes I have selected "recentwork" template in the Page settings. As for samboll, that's the article I used to set it up.

    If it makes any difference, my Recent Work page is actually my "blog" page. I haven't changed any of the php in any of the files. When I go to my recent page settings and select a different template it still references the "home" template. It's weird.

  5. @mercime
    Volunteer Moderator
    Posted 5 years ago #

    You might have mixed and matched different information in setting up a home page that could have caused the template behavior. Some questions come to mind
    -- Did you set a "page" as your static front page in Settings > Readings OR did you name your "home" page home.php?
    -- If you set a "page" as your static front page, did you also set the recentworks page as your blog in Settings > Reading?

  6. sdj entertainment
    Member
    Posted 5 years ago #

    Mercime - thanks for the advice, it turned out that the template name was home.php, switched it around and it works just fine. It's much appreciated.
    Cheers,
    Simon

Topic Closed

This topic has been closed to new replies.

About this Topic