WordPress.org

Ready to get started?Download WordPress

Forums

[resolved] Template shifts left a few pixels on single post (3 posts)

  1. erikas_boy
    Member
    Posted 4 years ago #

    Okay,
    I'm working on skinning a template (actually, just the default one) for a client site, and it's doing something funny.

    Load up the main page:
    http://www.orosend.com/joomla/blog/
    then click the post. Notice how the "page" div moves left a few pixels? Any idea why? Firebug shows that the .css isn't changing (at least not as far as I can see), and there doesn't seem to be any validation problems (none that should affect that, anyways).

    I can post code from whatever files are helpful. Any help is appreciated, I'm no noob to .css, PHP and skinning CMS templates, but this one is giving me heart-ache.

    Thanks, Chris.

  2. alchymyth
    The Sweeper & Moderator
    Posted 4 years ago #

    there is a display problem in IE7, on single.php:

    caused by the negative margin:

    .widecolumn {
    	float: left;
    	padding: 0 0 20px 5px;
    	margin: -53px 0 0 5px; /*165px*/
    	width: 450px;
    	}

    to your question: rock solid - no horizontal shift between index.php and single.php in IE7 and firefox3.5.8;

    check on your monitor if the vertical scroll bar kicks in on the longer single.php.

  3. erikas_boy
    Member
    Posted 4 years ago #

    alchymyth,
    Thanks for the quick reply. I hadn't even started working it in IE yet, I knew the negative margins would need to be hacked a bit.

    Oh dear, of course, the scroll-bar. Always spending too much time looking for a complicated solution when the answer is so damn obvious.....

    Thanks so much.

Topic Closed

This topic has been closed to new replies.

About this Topic