WordPress.org

Ready to get started?Download WordPress

Forums

[resolved] template pages not showing in dropdown list (21 posts)

  1. abovocipher
    Member
    Posted 4 years ago #

    I am currently using wordpress 2.8.2. I used to be able to select the template page when I was editing the page, now it doesn't seem to show up. I did find the template dropdown box when doing "quick edit" but didnt see the template page that I created.

    Previous pages that I created with version 2.8 still work but don't show the template they are using. Any suggestion on how to get that back? Or should I just go back to 2.8?

    Any help would be much appreciated.

  2. esmi
    Forum Moderator
    Posted 4 years ago #

    Check that each of your custom templates have the following block at the very top of the file:

    <?php
    /*
    Template Name: Name_of_Template_for_Dropdown
    */
    ?>
  3. abovocipher
    Member
    Posted 4 years ago #

    yup, that's what they looked like. They showed up before when I was running 2.8

    Since I upgraded to 2.8.2 the template option doesn't even show up in the regular edit.

  4. esmi
    Forum Moderator
    Posted 4 years ago #

    Have you checked that the custom template(s) haven't been damaged? I've not had any problems at all with page templates in 2.8.2.

    Have you tried deactivating all plugins in case one of them is interfering?

  5. abovocipher
    Member
    Posted 4 years ago #

    I just double checked the template files and they looks the same as what they were before. They also still work on my page. Here are some screen shots of what I see:

    https://jeffmillies.com/image-hosting/wp-edit.jpg
    https://jeffmillies.com/image-hosting/wp-quickedit.jpg

    seems kind of odd to me, what version are you running?

  6. abovocipher
    Member
    Posted 4 years ago #

    well I downgraded wordpress to 2.8.1 and the same thing and then down to 2.8 and still had the same thing. I could have sworn that there was a drop down menu for the template's on the main edit screen, but it is lost now. :/

  7. esmi
    Forum Moderator
    Posted 4 years ago #

    what version are you running?

    2.8.2 mainly but I have a couple of client sites still running 2.8.1 or 2.7. Not come across this problem on any of them. Sorry I can't help. :-(

  8. abovocipher
    Member
    Posted 4 years ago #

    update--

    installed wordpress in another folder and created a site there using 2.8.2 and the template drop down shows up in there. So I went ahead an replace all the core files of wp with those new files and still nothing. I'm thinking that its a database issue.. which I don't anything about really, just how to back it up.

  9. @mercime
    Volunteer Moderator
    Posted 4 years ago #

    One fix to this dropdown problem - it works for me - in either pages and authors name in write panel is to "jog" the system by changing your custom theme to default theme and FTP upload the page templates you made in original theme to default theme folder.

    Go to Pags > Add New and check if dropdown for page template is there. If you see it there, then system's been "jogged". Change theme back to your custom theme and in all probability the page template dropdown is there.

    If not, go change theme to classic theme and FTP upload your page templates there and check for the dropdown in Pages > Add New. Again, if you see it then change theme back to custom theme.

  10. abovocipher
    Member
    Posted 4 years ago #

    GENIOUS!! I don't know how I missed that. I went to the theme section in the control panel and nothing was selected, so I activated the theme that I was using and it works now.

    Thanks a ton mercime :D

  11. ws0x9
    Member
    Posted 4 years ago #

    This happened to me also when I updated to 2.8.2.

    It seems that my default theme was dropped in the process. All I did was activate it again the "Template" option for pages came back.

  12. hkohistani
    Member
    Posted 4 years ago #

    Same thing happen to me, I followed mercime directions above but it still it didn't show when I changed the theme to classic, BUT when I changed back to my theme I was using the template drop appeared! Very Quirky and I hope this helps anyone.

  13. Jonathan Desrosiers
    Member
    Posted 4 years ago #

    Wow thanks mercime. How did you think of that? Excellent concept.

  14. newmok
    Member
    Posted 4 years ago #

    It works for me too...
    Thanks mercime!!!

  15. Momekh
    Member
    Posted 4 years ago #

    @Mercime: you, my friend, probably have a cape around your back, don't you? Thank m'man. I renamed the theme folder, and then FTP'ed the original theme folder, but for some reason, WP automatically changed to keep the 'renamed theme folder' as the selected theme. Thanks to you, now I know WordPress jogs too :/ :)
    Check out my site at http://www.feztrick.com :)

  16. LambWarren
    Member
    Posted 4 years ago #

    @abovocipher + @Mercime: Thank you both. Was having the same problem, I also went to the Theme section in Settings, nothing was selected so I selected my own theme, and FIXED.

  17. Dharmishta
    Member
    Posted 4 years ago #

    Thank you! This worked for me too!

  18. pajtai
    Member
    Posted 4 years ago #

    BAM! It worked for me too!

    I'm not sure how it happened, but I didn't have a theme selected on the themes page. My custom theme looked to be working properly, but for some reason it just wasn't selected in the control panel. I went ahead and selected it, and now the themes show up!

  19. franclin
    Member
    Posted 4 years ago #

    Merci, mercime! Saved me hours of therapy.

  20. michaelhowlett
    Member
    Posted 4 years ago #

    Thank you Mercime. Worked perfectly!

  21. theresacambria
    Member
    Posted 4 years ago #

    thank you!

Topic Closed

This topic has been closed to new replies.

About this Topic