WordPress.org

Ready to get started?Download WordPress

Forums

Template looks different in web server (3 posts)

  1. hildergarn
    Member
    Posted 2 years ago #

    I recently edited a template I downloaded on localhost and it looks OK according to what I need. Now that I bought some hosting online I upload the same template, with every image, css and everything but it looks different (and ugly by the way).

    Am I missing or forgot something to upload to the hosting? I really don't have any clue on this issue :S

  2. michael.mariart
    Member
    Posted 2 years ago #

    It looks like your site (the hosted one) is missing it's image files and CSS files. This doesn't mean that they are not there, it means that your site is looking for them from your local computer, and it can't find them.

    When you uploaded the theme to the new hosting account, did you use a fresh install or did you move the database from your local install to the hosting server as well? If you moved the database that's your problem. You need to change the URL of the system in the admin area, and you should be able to see the images and CSS again.

    One thing that can help is to use FireBug to see the URL's that all of the files are being requested from. You'll easily see if anything is 404 (not found).

  3. hildergarn
    Member
    Posted 2 years ago #

    Hey Michael! I got one css file missing and it solved most of the issue, although the widgets don't show :S

    Do you know if there's a file I have to check to get all the existing widgets on their place?

    Thanks :)

Topic Closed

This topic has been closed to new replies.

About this Topic