WordPress.org

Ready to get started?Download WordPress

Forums

[resolved] Template editor is not working (8 posts)

  1. krioteh
    Member
    Posted 2 years ago #

    If you try to edit the template for any child says "file not found"

    Is this a bug?
    Or need to change the child templates?

    WP 3.4-alpha-20169

  2. esmi
    Forum Moderator
    Posted 2 years ago #

    Issue confirmed here. I'll try to make sure that this one gets through to the right people.

  3. Andrew Nacin
    Lead Developer
    Posted 2 years ago #

    I can't quite reproduce this. If I go to Appearance > Editor, everything will work. There are some 'Edit' links in the UI that will no longer work, but that is a temporary issue that will be fixed in http://core.trac.wordpress.org/ticket/20103.

    Can you describe the steps to reproduce? The theme editor hasn't been updated to use a new API yet as a test of backwards compatibility — so I just want to rule out what's going on here.

  4. esmi
    Forum Moderator
    Posted 2 years ago #

    Version 3.4-alpha-20169. My local copy includes a completely bare bones 2011 child them. If I navigate to Appearance -> Editor and use the select/dropdown to select that child theme, the "Edit Themes
    Twenty Eleven Child:" heading appear followed by:

    Oops, no such file exists! Double check the name and try again, merci.

    in a standard red-bordered error div. I've got debug turned on, so I'm also seeing the following warnings:

    Warning: array_merge_recursive() [function.array-merge-recursive]: Argument #1 is not an array in E:\data\data3\server\bitesize\wp-includes\class-wp-theme.php on line 931

    Warning: Invalid argument supplied for foreach() in E:\data\data3\server\bitesize\wp-includes\class-wp-theme.php on line 932

    Warning: array_merge_recursive() [function.array-merge-recursive]: Argument #1 is not an array in E:\data\data3\server\bitesize\wp-includes\class-wp-theme.php on line 931

    Warning: Invalid argument supplied for foreach() in E:\data\data3\server\bitesize\wp-includes\class-wp-theme.php on line 932

    These warnings appear to be specific to the error.

    Screenshot

  5. I can reproduce it on my site too (Multisite)

    Warning: array_merge_recursive() [function.array-merge-recursive]: Argument #1 is not an array in /home/ipstenu/public_html/wp-includes/class-wp-theme.php on line 931
    
    Warning: Invalid argument supplied for foreach() in /home/ipstenu/public_html/wp-includes/class-wp-theme.php on line 932
    
    Warning: array_merge_recursive() [function.array-merge-recursive]: Argument #1 is not an array in /home/ipstenu/public_html/wp-includes/class-wp-theme.php on line 931
    
    Warning: Invalid argument supplied for foreach() in /home/ipstenu/public_html/wp-includes/class-wp-theme.php on line 932

    Oh and I don't have debug turned on.

  6. Looks to be resolved now for me. Anyone else?

  7. krioteh
    Member
    Posted 2 years ago #

    I got the answer. Thank you.

  8. esmi
    Forum Moderator
    Posted 2 years ago #

    Fixed for me in 3.4-alpha-20192

Topic Closed

This topic has been closed to new replies.

About this Topic

Tags

No tags yet.