WordPress.org

Ready to get started?Download WordPress

Forums

Contact Form 7 Phone Module
Telephone Mask broken in CF7 v3.7 (6 posts)

  1. starlinggirl
    Member
    Posted 5 months ago #

    Since installing the update of Contact Form 7 to version 3.7, Contact Form 7 Phone Module version 2.3.4.1 no longer works. I was using this tag:[phone* your-phone mask:(999)999-9999] and now I get this error:

    Fatal error: Call to a member function shortcode_parse_atts() on a non-object in /home/smgwebadmin/seattlemetalsguild.org/wp-content/plugins/contact-form-7-phone-mask-module/phone.php on line 73

    Does anyone know how to fix this? In the meantime, I am using [tel* tel-81] which works, but no mask.

    Super newbie, so any assistance is greatly appreciated! Thanks!

    https://wordpress.org/plugins/contact-form-7-phone-mask-module/

  2. gradient9
    Member
    Posted 5 months ago #

    Same issue here. Any luck?

  3. GottaGetEm
    Member
    Posted 4 months ago #

    To get the CF7 Phone Mask plug-in to work again I uploaded a previous version of Contact Form 7 and everything went back to normal. I had to go back to the 3.6 version.

    You can find previous versions here:
    http://wordpress.org/plugins/contact-form-7/download/

    I tested and received the form with the proper phone number showing.

    I hope it works out.

  4. Wbennet
    Member
    Posted 4 months ago #

    WP changed file shortcodes.php, and these functions have been changed:
    NEW
    function wpcf7_add_shortcode( $tag, $func, $has_name = false ) {
    $manager = WPCF7_ShortcodeManager::get_instance();

    OLD
    function wpcf7_add_shortcode( $tag, $func, $has_name = false ) {
    global $wpcf7_shortcode_manager;
    if ( is_a( $wpcf7_shortcode_manager, 'WPCF7_ShortcodeManager' ) )

    So we need to change the code in there phone.php within plugins/contact-form-7-phone-mask-module

    Wilton Bennet

  5. Gabriel Reguly
    Member
    Plugin Author

    Posted 3 months ago #

    Thanks for sharing your solutions.

  6. diegodgogd
    Member
    Posted 3 months ago #

    sorry, but in my case, when I inserted the phone tag in the form, it doesn't load. The page loads with the header, footer, but the form not.
    Wbennet posted some line codes, but I can't find in the phone.php file.
    How can I resolve this?
    Thanks

Reply

You must log in to post.

About this Plugin

About this Topic