WordPress.org

Ready to get started?Download WordPress

Forums

[resolved] target="_blank" doesn't appear to work (4 posts)

  1. Johnny Bravo
    Member
    Posted 4 years ago #

    hi
    im trying to make my footer social media links open in a new window when clicked. i have tried adding target="_blank" but i think im just not adding it in the correct place on each link. im adding it right at the end after border="0" but the links still open in the same window.

    my footer.php file:

    <?php
    /**
     * @package WordPress
     * @subpackage Default_Theme
     */
    ?>
    
    <div class="clear"></div>
    
    </div>
    	</div>
        	</div>
    
    </div>
    
    <div id="footer" role="contentinfo">
    	<div class="footer_content">       
    
           	<?php wp_page_menu('show_home=1&exclude=385, 389, 392, 398, 400, 404, 407&menu_class=footer_menu'); ?>
    
            <div class="footer_share_box">
                <img src="<?php bloginfo('template_url'); ?>/images/share1.gif" alt="" title="" border="0" />
                <a href="<?php echo get_option('home'); ?>/feed/rss/"><img src="<?php bloginfo('template_url'); ?>/images/rss.gif" alt="" title="" border="0" /></a>
                <a href="http://digg.com/submit?phase=2&url=<?php echo get_option('home'); ?>"><img src="<?php bloginfo('template_url'); ?>/images/digg.gif" alt="" title="" border="0" /></a>
                <a href="http://www.facebook.com/sharer.php?u=<?php echo get_option('home'); ?>"><img src="<?php bloginfo('template_url'); ?>/images/facebook.gif" alt="" title="" border="0" /></a>
                <a href="http://reddit.com/submit?url=<?php echo get_option('home'); ?>"><img src="<?php bloginfo('template_url'); ?>/images/reddit.gif" alt="" title="" border="0" /></a>
                <a href="http://twitthis.com/twit?url=<?php echo get_option('home'); ?>"><img src="<?php bloginfo('template_url'); ?>/images/twitter.gif" alt="" title="" border="0" /></a>
                <a href="http://www.stumbleupon.com/submit?url=<?php echo get_option('home'); ?>"><img src="<?php bloginfo('template_url'); ?>/images/stumble.gif" alt="" title="" border="0" /></a>
            </div>
    
            <div class="footer_copyright">
            www.artbyHerbie.com  &copy; 2009 - All Rights Reserved<br />
            Web Design by Herbie. Who did you think?<br />
            <a href="http://www.facebook.com/herbiehysteria=<?php echo get_option('home'); ?>"><img src="<?php bloginfo('template_url'); ?>/images/facebottom.gif" alt="Become a Fan!" title="" border="0" /></a>        <br />
            </div>
    
      </div>
    </div>
    
    </body>
    </html>

    regards
    HH

  2. Johnny Bravo
    Member
    Posted 4 years ago #

    never mind, ive sorted it
    HH

  3. Samuel B
    moderator
    Posted 4 years ago #

    [sarcasm]thanks for posting the resolution for others[/sarcasm]

  4. Johnny Bravo
    Member
    Posted 4 years ago #

    target="_blank" went in straight after the second ". Before the ><img src=... Links work fine now.

Topic Closed

This topic has been closed to new replies.

About this Topic