WordPress.org

Ready to get started?Download WordPress

Forums

WP to Twitter
[resolved] Tag(s) not displayed in tweets (11 posts)

  1. Miroslav
    Member
    Posted 1 year ago #

    Hi,

    I'm trying to figure out why my tags don't show in my tweets. My basic settings are: #tags# #title# #url#

    ... but the tweets always start with the title and tags are never displayed. Any ideas?

    Great plugin, thanks!

    http://wordpress.org/extend/plugins/wp-to-twitter/

  2. Joe Dolson
    Member
    Plugin Author

    Posted 1 year ago #

    Tags can be a little finicky. What are your settings for tags--length allowed, number of tags, etc?

  3. Miroslav
    Member
    Posted 1 year ago #

    Strip nonalphanumeric characters from tags: unchecked
    Use tag slug as hashtag value: unchecked
    Maximum number of tags to include: 3
    Maximum length in characters for included tags: 15

  4. Joe Dolson
    Member
    Plugin Author

    Posted 1 year ago #

    So, defaults, then. I've not generally encountered problems with those settings - I'll test and see if I can find something.

  5. Miroslav
    Member
    Posted 1 year ago #

    Yes, defaults.

    I don't know if it helps, but the post format is Link and the posts are created from outside the usual WP UI by the Linkmarklet plugin.

    However, the tags are properly shown in the backend.

  6. Joe Dolson
    Member
    Plugin Author

    Posted 1 year ago #

    That's definitely very helpful - important information. When information is posted from a non-standard WP UI, that can radically change how things work when interacting with other things. I'll check it out, but may not be able to do anything about it.

  7. Miroslav
    Member
    Posted 1 year ago #

    OK, I understand. I would appreciate it if you let me know if you managed to find what the problem is and whether you're able to fix it. In case the problem is with the other plugin, it would be helpful to know what to tell the plugin developer. Thank you very much for taking the time!

  8. Joe Dolson
    Member
    Plugin Author

    Posted 1 year ago #

    Hi, Miroslav - I did find the issue. The problem is that the Linkmarklets plug-in sets the post status to 'publish' *before* inserting the tags. Since WP to Twitter sends Tweets on publication, the tags do not yet exist when the Tweet is sent.

    It's a very easy fix to make for the developer of Linkmarklets (just changing the order of events in that plug-in), but there's nothing I can do about it in WP to Twitter.

    For a more immediate fix, you can just use the future publish functionality in Linkmarklets - if you schedule things for the future (even a couple minutes in the future), then the tags will be present when the Tweet is created.

  9. Miroslav
    Member
    Posted 1 year ago #

    Wow, Joe! Thank you very much for coming back to me on this. I will let the Linkmarklet developer know. Thank you, again!

  10. Jonathan Christopher
    Member
    Posted 1 year ago #

    Thanks a ton for the helpful feedback, this issue has been resolved in Linkmarklet 0.7 available now.

  11. Miroslav
    Member
    Posted 1 year ago #

    Working now! Thank you, both!

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic

Tags

No tags yet.