WordPress.org

Ready to get started?Download WordPress

Forums

Media Library Assistant
[resolved] Tagged images - nothing found (4 posts)

  1. LingoSam
    Member
    Posted 1 year ago #

    We have a site that we wish to essentially be a large image gallery of our clients work.

    We have uploaded a large amount of images to a WordPress build location.
    These have then been tagged with appropriate tags using MLA.

    If we add one of the used tags as a menu option (Via appearance>menus>tags), when clicking this new menu link, for instance it says 'nothing found'.
    http://exampledomain.com/tag/2010/

    Why is this? Is it because the inbuilt tag template is looking for posts with tags, rather than media?

    I noticed if we just used the slug at the end of the domain name, for instance:
    http://exampledomain.com/2010/
    This does make a gallery of the tagged images, however some of the many tags we have in this fashion don't work.

    How can we get around this? Are we approaching this wrong?

    Our ideal scenario is we have a selection of tags that the browser can click on, which filters down the images to exactly what they want to see.

    http://wordpress.org/plugins/media-library-assistant/

  2. David Lingren
    Member
    Plugin Author

    Posted 1 year ago #

    Thanks for your interest in the plugin and for this question.

    You've made some progress already. You're right, the "domain/tag/term" or "domain/term" syntax doesn't do what you want because the query is for posts and pages, not attachments.

    Taxonomies, attachments and filtered displays have been the subject of several support topics. Here are four topics that should give you a lot of helpful information:

    Pagination Revisited

    Building an archive gallery with MLA

    Category template please help

    Category template for Media Library Assistant with pagination

    These topics also address aspects of your question:

    How to Display Sub-Attachment Category Names

    Implementing Pagination

    Displaying Tags in Text Format

    listing attachment_category

    Excluding a category

    Have a look through these topics and see if they give you the approach you need. I am happy to address any problems or further questions you have, and I'll leave this topic unresolved for now.

  3. David Lingren
    Member
    Plugin Author

    Posted 1 year ago #

    I hope the suggestions I gave you in my earlier post gave you the help you needed. Since you haven't posted anything else here, I am going to mark this issue resolved. Please feel free to re-open it if you have more problems or further questions. Thanks again for your interest in the plugin.

  4. LingoSam
    Member
    Posted 1 year ago #

    They were very useful thank you.

    We ended up coming up with a custom solution (on top of the plugin) that did as we wished. You may mark this as closed / resolved.

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic