WordPress.org

Ready to get started?Download WordPress

Forums

Tagcloud catagories not linking properly (5 posts)

  1. GideonK
    Member
    Posted 8 years ago #

    Hi, hopefully this is not something I'm just overlooking but I'm having a problem.

    I recently installed Jerome's Keywords and keywords-tagcloud widget on my site ( http://www.exitium.info ). I really like the look and feel of it, but the links don't actually work, instead just showing the full list of my entries (well, the most recent.)

    Now, I've gone into the permalink section of the options and "updated" but I didn't see anything else there to do. Any ideas why these tags aren't working for me?

    Thanks!

  2. SterlingCamden
    Member
    Posted 8 years ago #

    Hi, I didn't see the tag cloud on your site, so I couldn't try out a tag search to see what you were talking about.

    I wrote the widget, and I have noticed one anomaly with tag searches using the Jerome's keywords plugin: it uses a LIKE clause in the SQL SELECT statement for retrieving posts by tag. The problem with that is if you have a tag "C", then any tag that contains a "C" will match. Johannes Jarolim identified a work-around for this that I haven't tried yet, but I don't think it will fix the plugin itself. You might need to modify the plugin code directly, or if I get around to it I might post a solution later.

  3. SterlingCamden
    Member
    Posted 8 years ago #

    With some help from Johannes, I posted a corrected version of the plugin here. Jerome has also released a new beta version here.

  4. justbishop
    Member
    Posted 7 years ago #

    I just downloaded and installyd Jerome's Keywords today, so I'm sure I have the corrected version mentioned above, however I'm still having the problem described by the threadstarter :/

    Here is my "tag cloud" page (yes, I wanted it showing up as an ABC list rather than a cloud). The list items are band names. For each entry that is an interview, I've put only the band's name as the tag: http://www.a-pathetic.net/zine/interviews/

    Here is my home page, and you can clearly see by comparing just the first few interviews with the band name tag list that these should be linking up and aren't: http://www.a-pathetic.net

    I've also done all I can do on the Options -> Permalinks page, including wiping my htaccess file and hitting the "update permalinks" button again. Nothing on my tag list page seems to change.

  5. justbishop
    Member
    Posted 7 years ago #

    Anyone?

Topic Closed

This topic has been closed to new replies.

About this Topic