WordPress.org

Ready to get started?Download WordPress

Forums

Events Manager
[resolved] Tag title not defined in site title (38 posts)

  1. Beee
    Member
    Posted 1 year ago #

    Yesterday I implemented tags into my system.
    I added two tags, IDF and IGSA.
    So far I only have events with the IDF tag.
    If I list all events with that tag, the site title =
    | SITENAME (http://www.freerides.org/events/tags/idf)
    instead of
    IDF | SITENAME
    For categories it works, but not for tags.

    I am using Yoast's WordPress SEO plugin.
    I defined specific tag titles for both tags as well as a description.
    I tried to display the tag description with #_TAGNOTES and #_CATEGORYNOTES.
    Both don't work.

    http://wordpress.org/extend/plugins/events-manager/

  2. agelonwl
    Member
    Posted 1 year ago #

    I get this too, I've let Marcus know about it. should get fixed soon.

  3. Beee
    Member
    Posted 1 year ago #

    thnx, awaiting the update...

  4. Marcus
    NetWebLogic Support
    Plugin Author

    Posted 1 year ago #

    yes, will fix asap, didn't think about doing the same changes/fix we applied to categories in the last update.

  5. Beee
    Member
    Posted 1 year ago #

    hm.... I get something weird...

    http://www.freerides.org/events/categories/freeride/
    http://www.freerides.org/events/categories/race/

    the title is displayed on one category but not on the other.
    I checked (to make sure) both categories have custom titles/descriptions.

  6. Marcus
    NetWebLogic Support
    Plugin Author

    Posted 1 year ago #

    have you tried 3.5.3? I've made some changes to the categories/tags page.

  7. Beee
    Member
    Posted 1 year ago #

    I think I posted this before I saw the update. Will check.

  8. Beee
    Member
    Posted 1 year ago #

    I think you mean 5.3.5 :)
    It's installed but no luck.
    See for yourself at:

    Title is displayed correct
    http://www.freerides.org/events/categories/freeride/
    http://www.freerides.org/events/tags/idf/

    Title is not displayed correct
    http://www.freerides.org/events/categories/race/

    BTW the tag IDF is only used with events in categorie race.

  9. AndalusianWorld
    Member
    Posted 1 year ago #

    How about showing included tags on Events main page?
    We are using the tags for country listings, so it would be very helpful

  10. Beee
    Member
    Posted 1 year ago #

    What good would that do ? Main events page has no errors.

  11. agelonwl
    Member
    Posted 1 year ago #

    Hi,

    Is it the same when creating new categories and/or re-saving that category?

  12. Marcus
    NetWebLogic Support
    Plugin Author

    Posted 1 year ago #

    Yup, i meant 5.3.5 :)

    That's wierd... can you spot anything different between the two plugins? There must be something between the two that's causing this to happen. I can't reproduce this.

  13. Beee
    Member
    Posted 1 year ago #

    I tried resaving the categories, didn't work.

    I saw there was something I haven't used before, namely an event with which lasted only one day. Namely Glory Hill Outlaw.

    I changed the status to pending review to test and voila... the correct titles appeared. I'll leave it there for now, so you can see the difference.
    http://www.freerides.org/events/categories/race/

    So imo it's located in a 1 day event.

  14. Beee
    Member
    Posted 1 year ago #

    more specific it's in #_EVENTDATES

    this is the code I use for each item

    <tr>
      <td valign="top">
     		#_EVENTDATES
    	</td>
      <td valign="top">
     		#_EVENTCATEGORIES
    	</td>
      <td valign="top">
      	#_EVENTLINK {has_location} in #_LOCATIONTOWN (#_LOCATIONCOUNTRY){/has_location}
      </td>
    </tr>
  15. Marcus
    NetWebLogic Support
    Plugin Author

    Posted 1 year ago #

    I still don't see how that can happen. e.g. on our demo site (which uses WP SEO) they are all all-day events

    https://demo.eventsmanagerpro.com/events/categories/easy-listening/

    Is there anything else that's special about that event? maybe some SEO setting or another plugin-related thing? Even then I can't imagine why that'd happen...

  16. Beee
    Member
    Posted 1 year ago #

    I get a security warning...

    How do you display dates there ? with #_EVENTDATES or #_{x} ?

    The one I put on pending review is not an all day event, but I didn't display its times. Does that make a difference ?

    (putting the item back online again now)

  17. Marcus
    NetWebLogic Support
    Plugin Author

    Posted 1 year ago #

    oops, I was logged in with ssl -

    http://demo.eventsmanagerpro.com/events/categories/easy-listening/

    I was using single placeholders, but I changed it to

    <li>#_EVENTLINK - #_EVENTDATES - #_EVENTTIMES</li>

    and it still works fine...

    i just don't see how programatically this can have an effect on the title of the page. i may be wrong, but I just can't imagine how it could...

  18. Beee
    Member
    Posted 1 year ago #

    I don't get it... If I remove Glory Hill the problem is gone, so I assume that causes it.

    Glory Hill Outhil Outlaw is a 1 day event with event times.

    Le Saint Patik #3 is a 2 day event with event times (have another issue with this item but I'll get to that in a seperate thread, since it's not related imo).

    All other events are multiple day, all day events.

    I can give you wp-admin access if you wanna take a look ?

  19. Marcus
    NetWebLogic Support
    Plugin Author

    Posted 1 year ago #

    i'm going to be looking at some other things regarding the category/tag pages so maybe when I do sort that out it may help. if still no then Ill consider having a closer look.

    what about if you create a test 1 day event, does it break the title then?

  20. Beee
    Member
    Posted 1 year ago #

    That 'test' one day event is just what is causing the problem with me. This post seems to be causing it (only on category pages now): http://www.freerides.org/events/glory-hill-outlaw/ because I put it on pending the error is gone.

    This is a 1 day event with specific event times (the rest has no times specified).

    I tried to add a day to the event, but it didn't work, no difference.

    I will create a login with the email address I have for you.

  21. Marcus
    NetWebLogic Support
    Plugin Author

    Posted 1 year ago #

    before that, please try creating a new event that lasts one day and see if that helps

    if it doesn't break it, try creating (don't duplicate) the offending event again and see if that breaks it

  22. Beee
    Member
    Posted 1 year ago #

    must it be an event which comes first in line ?
    as in with its date before Glory Hill Outlaw ?

  23. Marcus
    NetWebLogic Support
    Plugin Author

    Posted 1 year ago #

    try the same dates, different dates, etc. what we're trying to do is duplicate the creation of an event that causes this problem too in the same category. There must be a common denominator somewhere...

    if Glory Hill was the first event in line then try that too, you could try creating a replica but without using our duplicate function.

  24. Beee
    Member
    Posted 1 year ago #

    I created another event. Gave it the same details as the other one (except slug). Put the original event in pending. And it seems to works now.

  25. Beee
    Member
    Posted 1 year ago #

    what casused it ? NO IDEA !

  26. Marcus
    NetWebLogic Support
    Plugin Author

    Posted 1 year ago #

    i had a feeling... one of those cases where it's probably best not to ask why and move on :)

    glad you sorted it out!

  27. Beee
    Member
    Posted 1 year ago #

    lol... maybe it is... but it kinda puzzle(d) me.. :)
    glad it works, thanks for the help...
    appreciate it.

  28. Beee
    Member
    Posted 1 year ago #

    and we're back :)

    Sorry...

    I just added a (brand new) one day event again and it's on again...

    This was the category Misc, before I entered the event (I remember to take a screenshot before)
    http://i.imgur.com/ZehZRtx.jpg

    Then I took a screenshot after...
    http://i.imgur.com/TGIkHOY.jpg

    Is it me :) ?

  29. Beee
    Member
    Posted 1 year ago #

    oh btw, it only happens when you click the direct link to the subcategory.

    If you filter the events through the searchform, the title of the events page is used so nothing to be seen there.

  30. Marcus
    NetWebLogic Support
    Plugin Author

    Posted 1 year ago #

    so the question is... what are you doing specifically to trigger this?

    what's so special about the event info you're entering (or how you're entering it) to cause this event to create the problem?

    does it happen if you delete the event and re-create it like before?

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic