WordPress.org

Ready to get started?Download WordPress

Forums

Tag Object broken on WordPress 2.2 (4 posts)

  1. dondado
    Member
    Posted 7 years ago #

    I has some code in many posts at 2.1.3 looking like this:
    <object type=”application/x-shockwave-flash” data=”https://s3.amazonaws.com:443/slideshare/ssplayer.swf?id=47919&doc=genial-forges-18644″ height=”348″ width=”425″>
    <param name=”movie” value=”https://s3.amazonaws.com:443/slideshare/ssplayer.swf?id=47919&doc=genial-forges-18644″></param> </object>
    When i update to 2.2, the post came to look like:
    <object type=”application/x-shockwave-flash” data=”https://s3.amazonaws.com:443/slideshare/ssplayer.swf?id=47919&doc=genial-forges-18644″ height=”348″ width=”425″></p>
    `<param name=”movie” value=”https://s3.amazonaws.com:443/slideshare/ssplayer.swf?id=47919&doc=genial-forges-18644″></param> </object>
    Note the p tag terminator before then param tag
    I have to deactivate all plugins to ensure that they are'nt the problem. ¿Is there any quick solution or could i wait to next release for upgrading?.

  2. dondado
    Member
    Posted 7 years ago #

    the </p> tag causes that all the html code loss his structure, so i had to return to previos WP 2.1.3

  3. rsims
    Member
    Posted 6 years ago #

    Have you tried manually fixing from the Code tab and then publishing? As of 2.3.1 the WYSIWYG Visual mode still messes with slideshare embedded code. Going straight to Publish from Code (without ever going back to Visual mode) works for me.

  4. Samuel Wood (Otto)
    Tech Ninja
    Posted 6 years ago #

    Just disable the visual editor entirely. Users->Your Profile.

    The visual editor was made for people who don't understand HTML and only want to post text and maybe a few pictures. If you are pasting HTML in like Objects and such, then you likely don't need the visual editor at all.

Topic Closed

This topic has been closed to new replies.

About this Topic