WordPress.org

Ready to get started?Download WordPress

Forums

Types - Custom Fields and Custom Post Types Management
[resolved] Tag Links Result in Not Found (8 posts)

  1. th3wildcard
    Member
    Posted 10 months ago #

    I'm having a strange issue related to tags in my custom post types I'm creating. Each time I click on a tag link in a post, it results in a page stating,

    Nothing Found - Apologies, but no results were found. Perhaps searching will help find a related post.

    I have tried changing my permalink options back and forth, but to no avail.

    Can anyone offer a solution?

    http://wordpress.org/extend/plugins/types/

  2. mbigul
    Member
    Plugin Author

    Posted 10 months ago #

    Dear th3wildcard,

    Please let me know the following and steps to replicate the issue to track and debug it.

    1) Your WordPress version
    2) Your Types version
    3) PHP version and OS
    4) Other plug-ins you are using
    5) Your theme.

    [ Signature moderated. ]

  3. th3wildcard
    Member
    Posted 10 months ago #

    1) 3.5.1
    2) 1.3
    3) PHP 5.3 / Linux
    4) Quite a few. Any in particular that you know of that might cause this issue?
    5) Twentytwelve modified

  4. mbigul
    Member
    Plugin Author

    Posted 10 months ago #

    Dear th3wildcard,

    It is a rare issue. Therefore can you please try it after deactivating other plug-ins(Please take a back up before doing this). If issue exists swicth to default 2012 theme and check.

    Please let me know your feedback.

    [ Signature moderated. ]

  5. th3wildcard
    Member
    Posted 10 months ago #

    mbigul,

    Thanks for your assistance.

    I have shut down all my plugins one at a time and clicked the tag link, but am still receiving the same message mentioned before.

    Here are a list of plugins that are currently active, all updated to their respective latest versions:

    • BackupBuddy
    • CMS Tree Page View
    • CSS & JavaScript Toolbox
    • Cyclone Slider 2
    • Display widgets
    • Easy Columns
    • Enhanced Text Widget
    • Flexible Slider
    • Gravity Forms
    • NextGEN Gallery
    • Pages Links To
    • Promotion Slider
    • Super RSS Reader
    • Types - Complete Solution for Custom Fields and Types
    • WordPress SEO
    • WPshore Breadcrumbs
    • WP UI - Tabs, accordions and more
  6. mbigul
    Member
    Plugin Author

    Posted 10 months ago #

    Dear th3wildcard,

    I can replicate the issue. It is a WordPress behavior. Please add following code in your functions.php of theme to add custom post types to tag & category archives.

    <br />
    if ( ! function_exists( 'include_custom_post_types' ) ) {<br />
    function include_custom_post_types( $query ) {<br />
    if ( ! is_preview() && ! is_admin() && ! is_singular() ) {<br />
    $args = array(<br />
    'public' => true ,<br />
    '_builtin' => false<br />
    );<br />
    $output = 'names';<br />
    $operator = 'and';</p>
    <p>$post_types = get_post_types( $args, $output, $operator );</p>
    <p>$post_types = array_merge( $post_types, array( 'post' ) );</p>
    <p>if ($query->is_feed) {<br />
    } else {<br />
    $my_post_type = get_query_var( 'post_type' );<br />
    if ( empty( $my_post_type ) )<br />
    $query->set( 'post_type', $post_types );<br />
    }<br />
    }<br />
    } }<br />
    add_action( 'pre_get_posts', 'include_custom_post_types' );<br />

    [ Signature moderated. ]

  7. th3wildcard
    Member
    Posted 10 months ago #

    Thank you for your help, mbigul,

    I've applied the code, and it seems to corrected the issue.

    Out of curiosity, have you dealt with an issue where widgets don't appear on custom post type tag pages? Particularly in the footer?

    Thanks!

  8. th3wildcard
    Member
    Posted 10 months ago #

    I take it back. Unfortunately, the error is still persisting.

Reply

You must log in to post.

About this Plugin

About this Topic

Tags