WordPress.org

Ready to get started?Download WordPress

Forums

SemPress
[resolved] tag isn't applied for Firefox 19. (9 posts)

  1. suguru.hirahara
    Member
    Posted 1 year ago #

    Hello, thanks for the update for the theme.
    I've just noticed that you applied <main id="main"> tag in the theme, but it seems that the tag is yet to be supported by Firefox 19, so I think the div tag should be applied for that browser. Maybe by means of preg_match?

  2. pfefferle
    Member
    Theme Author

    Posted 1 year ago #

    I checked the tag in most of the new browsers and it should work fine, if the really support it or not. Do you have some specific problems?

  3. suguru.hirahara
    Member
    Posted 1 year ago #

    I see, I found it should be okay unless the CSS file is customized. If any rules for have been added for <div id="main">, they don't work for <main id="main"> on Firefox 19 and 20, too. I noticed that Chrome and IE handle the element without any problem. Don't you reproduce the issue on Firefox?

  4. suguru.hirahara
    Member
    Posted 1 year ago #

  5. pfefferle
    Member
    Theme Author

    Posted 1 year ago #

    Can you give me an example of a rule that doesn't work? I tested it with firefox 18 and 19 and it seemed to work fine.

  6. pfefferle
    Member
    Theme Author

    Posted 1 year ago #

    by the way... <div id="main"> is still present... i changed <div id="content"> to <main>

  7. pfefferle
    Member
    Theme Author

    Posted 1 year ago #

    ...and the css is using #content {} so the tag shouldn't matter...

  8. suguru.hirahara
    Member
    Posted 1 year ago #

    Ah, I overlooked that! Sorry for bothering you..
    Please keep up the nice work :-)

  9. pfefferle
    Member
    Theme Author

    Posted 1 year ago #

    no problem and thanks :)

Topic Closed

This topic has been closed to new replies.

About this Theme

About this Topic

Tags