WordPress.org

Ready to get started?Download WordPress

Forums

WP UI - Tabs, Accordions, Sliders
[resolved] tabtitle not working with special characters ( ) [ ] / (9 posts)

  1. thaleslqa
    Member
    Posted 1 year ago #

    when I use special characters ( ) [ ] / in tabtitle everything stops working

    http://wordpress.org/extend/plugins/wp-ui/

  2. kavingray
    Member
    Plugin Author

    Posted 1 year ago #

    Thanks for reporting, Please post the sample code. I will roll the fix into the next update.

  3. kavingray
    Member
    Plugin Author

    Posted 1 year ago #

    Fixed and update is on GitHub. https://github.com/kavingray/WP-UI ( Click Zip )

  4. thaleslqa
    Member
    Posted 1 year ago #

    Thank you. problem solved.

  5. illuminatus7
    Member
    Posted 1 year ago #

    Hey Kavin,

    This is still proving a proving an issue for me. I am using the content as here - http://pastebin.com/iBcet9Jv

    I am getting a JavaScript error as "Uncaught Error: Syntax error, unrecognized expression: #how_long_does_it_take_to_receive_my_xxx_print_once_ive_completed_my_order?"

    Can you please check this?

    Thanks!

  6. Jean Goodwyn
    Member
    Posted 1 year ago #

    This is not resolved; I'm using the current version of the plugin, and using periods and commas in the tab title breaks it.

  7. nludwig
    Member
    Posted 10 months ago #

    I am reporting the same issue. A period breaks the tab.

  8. SV
    Member
    Posted 10 months ago #

    The problem is following replace statement in wp-ui.js:

    .replace(/[^A-Za-z0-9\s_\-]/m,'')

    It's removing special characters from the title, but it's only removing the first instance.

    replace it with:

    .replace(/[^A-Za-z0-9\s_\-]/gm,'')

    The wp-ui.js file is packed with dean edwards packer. So you have to unpack it first.

  9. Mickey Kay
    Member
    Posted 10 months ago #

    This is particularly problematic for translated pages that use special language characters (e.g. Chinese). I currently have the "Use Old Scripts API" option checked, which solves the problem, but I'd love to see the latest version of this plugin work too. It seems that every time I update this plugin, I still have to check this box, despite all the assurances that things should now be working.

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic

Tags

No tags yet.