WordPress.org

Ready to get started?Download WordPress

Forums

Shortcodes Ultimate
[resolved] Tabs start in last tab! (4 posts)

  1. Daraiko
    Member
    Posted 9 months ago #

    Hi,
    When adding a "Tab" with 3 tabs, when the page loads, it is always inside tab3 and not tab1.. kind of annoying.

    Please help

    http://wordpress.org/plugins/shortcodes-ultimate/

  2. dccharron
    Member
    Posted 9 months ago #

    Put you page or post in "Text" view to reveal the html code. You should see something like:

    [su_tabs active="3"]
    [su_tab title="Title 1"]Content 1[/su_tab]
    [su_tab title="Title 2"]Content 2[/su_tab]
    [su_tab title="Title 3"]Content 3[/su_tab]
    [/su_tabs]

    Tabs (with an "s") is like a container for the all the tabs you want. Tab (without an "s") goes between [su_tabs] and [/su_tabs]. I've displayed an example above. (Note this is with Settings => Compatibility Mode box checked which turns on the "su_" prefix).

    In the [su_tabs] shortcode there is a parameter that says 'active="3"'. This controls which tab is presented when first opening the page. If you don't put any parameter, it should default to the first tab. In the example I've shown, it should open in tab 3.

  3. Daraiko
    Member
    Posted 9 months ago #

    Brilliant!

    Thankyou dccharron!
    I just put "1" and it start with the first tab :)
    putting nothing will break it though!

    Thanks a mill! :)

  4. dccharron
    Member
    Posted 9 months ago #

    Happy you were able to fix your problem.

    I'm using an older version of the plugin (by choice) and don't experience the problem you have when just using [su_tabs] without any "active" parameter. Perhaps this is a new problem with 4.4.4?

    For those who have updated to 4.4.4 it is good to know that adding active="1" to [su_tabs] is a workaround.

Reply

You must log in to post.

About this Plugin

About this Topic

Tags