WordPress.org

Ready to get started?Download WordPress

Forums

TablePress
[resolved] Tablepress Disappears on Site Migration (6 posts)

  1. underWorded
    Member
    Posted 1 year ago #

    Hi Tobias, great plugin, best for tables I've seen so far just one problem - I've just migrated a wordpress site from a subdomain where I was testing it for a client to the main domain, and now TablePress has vanished from the dashboard.

    Also, on each page where there's a TablePress table it simply says 'not found'

    Here's what I've done to try to fix it, none of which works:

    1 Uninstalled and reinstalled TablePress. It now refuses to register on the dashboard.
    2 Disabled all other plugins then re-enable TablePress
    3 When I exported the site from the subdomain, TablePress was included in the options
    4 I've looked in the database and there appears to be no reference to TablePress entries

    I exported all tables as .csv prior to migration, but it's going to be a pain reinserting them manually - hope you can help!

    http://wordpress.org/extend/plugins/tablepress/

  2. TobiasBg
    Member
    Plugin Author

    Posted 1 year ago #

    Hi,

    this sounds weird. So, you can access TablePress, but it doesn't have any of your tables?

    1) What does "refuses to register" mean?
    3) Which export method is that?
    4) Are there any posts in the "wp_posts" table with a value of "tablepress_table" in the "post_type" column?

    About the CSV files: Just put them in a ZIP archive, as TablePress can import ZIP archives with CSV files in them.

    And: Do you still have access to the old site (on the subdomain)?

    Regards,
    Tobias

  3. underWorded
    Member
    Posted 1 year ago #

    Hi Tobias, thanks for replying so promptly, it's appreciated!

    No I can't see TablePress at all. No matter whether I uninstall then reinstall. And the other plugins were the same as on the subdomain - so I don't think there's a conflict.

    1) That's what I mean by "refuses to register" - the plug in simply doesn't show up in the dashboard. The plugin is definitely activated but doesn't show up.
    2) The export option in your plugin that enabled me to export all tables as .csv files in one zip file
    3) Yes there are 'tablepress_table' entries in the wp_posts table! Not sure how I missed them, sorry.

    The subdomain was using the same database as the main one - so I was required to clear it to install on the main domain.

    Thanks for your help.

  4. TobiasBg
    Member
    Plugin Author

    Posted 1 year ago #

    Hi,

    argh, I still can't really make sense of what might have happened here.
    It might be a good idea, if I take a direct look at this in your admin area.

    Can you therefore please send me an email (the address is in the main plugin file "tablepress.php")?

    Regards,
    Tobias

  5. underWorded
    Member
    Posted 1 year ago #

    Tobias, thanks again for your amazingly prompt and effective support via email. The issue as you say was access rights and now everything is working perfectly!

    Keep up the good work - you're a star!

  6. TobiasBg
    Member
    Plugin Author

    Posted 1 year ago #

    Hi,

    no problem at all! You are welcome! Yes, this was an issue with the user rights, probably related to moving the sites. But the fix was easy, so you can now use the plugin :-)

    Best wishes,
    Tobias

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic

Tags

No tags yet.