WordPress.org

Ready to get started?Download WordPress

Forums

Table prefix change: Topics don't show, New topics go to table with old prefix (3 posts)

  1. Expana
    Member
    Posted 2 years ago #

    Hi guys,

    I feel the answer is very close, just don't know which file to look in.
    Could anyone please assist with the below?

    My db prefix was wp_
    Using a security plugin I changed prefix wp_ to, say, mynewprefix_

    The result:

    1) DB side:

    I was not able to log in to the phpMyAdmin under the old db user name. (But I was able to log in to WordPress Admin pages)
    I created a new one db user and logged in successfully.

    In wp-config.php I still see

    /** MySQL database username */
    define('DB_USER', 'myolddbuserloginname');
    /** MySQL database password */
    define('DB_PASSWORD', 'encryptedpasswordhere');

    Should I change a db user here? (may be it causes what happens in "2)" below)
    If yes, how do I get an encrypted password?

    2) Web-site:

    Posts, Plugins, and Groups showed up after the prefix change, but
    Forums does display. Neither forum topics nor forum tags.

    I created a topic. It saved, it see it in the web-site, but no old topics.

    I used this link http://tdot-blog.com/wordpress/6-simple-steps-to-change-your-table-prefix-in-wordpress
    and manually went through steps. I found a couple of places with wp_ and changed them to mynewprefix.

    In the PhpMyAdmin I see that I have several tables dublicated. Eg:
    I see mynewprefix_bb_topics and wp_bb_topics.
    The first table contains all old topics, the second table has the only the topic I created after the changing the prefix using the plugin.

    So it looks like all old topics exist, which is good.
    But WordPress or buddypress does not see the renamed tables. And it writes all new topics to tables that becomed named with an old prefix (wp_).

    What am I missing? Where?

    Thanks heaps for your help. I looked through everything I could think of...

    Natalie

  2. Expana
    Member
    Posted 2 years ago #

    Sorry for misprints, it was too late here :(

  3. Expana
    Member
    Posted 2 years ago #

    I was advice with the solution!

    Group forums uses bb-config.php.

    I found 3 entries in that file that lead to wp_
    Updated them to my new prefix. And it worked like a charm :)

    Best wishes,
    Nat

Topic Closed

This topic has been closed to new replies.

About this Topic