WordPress.org

Ready to get started?Download WordPress

Forums

TablePress
[resolved] Table no longer sorting by initial date column (4 posts)

  1. sporulia
    Member
    Posted 1 year ago #

    Hi Tobias

    Some months ago you helped me display a table with an initial view sorted by a date column, most recent first.

    Here's the thread: http://wordpress.org/support/topic/sorting-by-date-with-data-tables-sorting-extension

    and the page in question: http://www.papuansbehindbars.org/?page_id=17

    Now it has stopped working without any obvious reason:
    These are the symptoms:

    1. The table now sorts by the correct column date ascending (oldest first) although some recent additions to the data are not properly sorted.

    2. That column can no longer be sorted by the user (all other columns are sortable as normal)

    3. The website is bilingual (using qtranslate). Strangely, the Indonesian version was working as normal even after the English version broke. but now they are both not working.

    I'm at a total loss for where to start looking for a solution. There have been no changes to the site in the meantime except for adding content, and the text in the 'custom-commands' field remains the same:
    "aaSorting": [[3,'desc']], "aoColumnDefs": [ { "sType": "date-eu", "aTargets": [ 3 ] } ]

    I've tried disabling all the other plugins, but the problem remains. Could it be that the table just got too big maybe?

    http://wordpress.org/extend/plugins/tablepress/

  2. TobiasBg
    Member
    Plugin Author

    Posted 1 year ago #

    Hi,

    thanks for your post, and sorry for the trouble.

    My assumption here is, that this is caused by the third row, where the date is "Unknown". This is not supported at the moment. All cells in that column must be a date. Also, the very last row seems to be empty, so you should remove that.

    Regards,
    Tobias

  3. sporulia
    Member
    Posted 1 year ago #

    Thanks Tobias,
    indeed that was the problem
    it's working fine now... a blank space seems ok, the word 'unknown' was the problem

  4. TobiasBg
    Member
    Plugin Author

    Posted 1 year ago #

    Hi,

    very nice! Great to hear that this fixed the problem! :-)

    Best wishes,
    Tobias

    P.S.: In case you haven't, please rate TablePress here in the plugin directory. Thanks!

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic