WordPress.org

Ready to get started?Download WordPress

Forums

table formatting - paragraph marks dissapear (9 posts)

  1. Kristad
    Member
    Posted 2 years ago #

    Hi
    I am having trouble with table formating.
    I have a suite name/number and a one sentence description. Everytime I make a change to the text, the paragraph marks dissapear and the two sentences are on one line. Can someone explain why this is happening and how to keep the paragraph marks?

    An example is at:
    http://www.kelownaresortaccommodations.com/sunset-1-bedrooms

    I am using Word Press 3.1.3.

    Thank you so much in advance.
    K.

  2. hotplugin
    Member
    Posted 2 years ago #

    plz explain your issue more.

  3. Kristad
    Member
    Posted 2 years ago #

    I will explain a little more details...
    I view in the visual editor, and put a return between two sentences.

    When I go back to the page later, and make another change to any text, the previous paragraph marks dissapear.

    I have gone into the html view and inserted <p> tags. Once I do that, if I go back to the page and edit the text, and update, all the <p> dissapear.

    I don't know why the paragraph <p> tags dissapear after I make an edit to the text on the page...
    Hopefully this gives more detail to my problem.
    Thank you again.

  4. hotplugin
    Member
    Posted 2 years ago #

    this is new. but i think you don't need to actually add those tags yourself. just use the default Paragraph option in editor. it should work fine.

  5. Kristad
    Member
    Posted 2 years ago #

    Hi - when I hit the return button, it puts the paragraph mark but later if I go and make an edit to the change, that paragraph mark dissapears. I have tried it in the view editor and in the html editor. Very strange. Any other thoughts?

  6. jacksonmurphy
    Member
    Posted 2 years ago #

    This has been an issue I've been dealing with for some time. Specifically with content that has paragraphs inside a table cell. When I hit publish, I lose the paragraph spacing on some of the text. Then when I fix those paragraphs, it will cause other paragraphs to lose its formatting. It's a very frustrating for my clients and me. I haven't found an answer or solution to the problem yet.

    Any ideas to what can be done to fix this issue?

  7. JboyJW
    Member
    Posted 1 year ago #

    As far as I know, this issue has been around since 3.1. I even stopped upgrading at 3.0.4 for any sites where I knew the client would need to edit tabular data. For security reasons, it's time to upgrade these and I'd REALLY like this issue to be fixed.

    To reiterate, the problem happens when creating paragraphs in a table cell. When I hit enter to create a new paragraph within a table cell, it looks fine. When I hit Update/Publish, when the page refreshes, WordPress converts that paragraph break into a single line break. If I then click Update again, WordPress removes that linebreak entirely and the paragraphs are essentially merged.

    I can also reproduce this behaviour without even clicking Update. If you just switch to HTML mode and then back to Visual mode, the same issue happens.

    This is definitely a bug and I've created a bug report for it http://core.trac.wordpress.org/ticket/20943. Hopefully this will be attended to.

  8. fredlim
    Member
    Posted 1 year ago #

    I have the same problem in version 3.5. I install the "MCE Table Plugin" for create table. In the table cell, when I save the same post again, the first paragraph lost its attribute and the 2nd paragraph will merge with the first paragraph.

    That is a showstopper, is there workaround available?

  9. Andrew Nevins
    Spam zapper & Volunteer Moderator
    Posted 1 year ago #

    Fredlim,

    Create your own thread on the issue.

Topic Closed

This topic has been closed to new replies.

About this Topic

Tags

No tags yet.