WordPress.org

Ready to get started?Download WordPress

Forums

[resolved] Table data cell issue on page (12 posts)

  1. Drew75
    Member
    Posted 8 months ago #

    I'm trying to adjust the way our dealers display on a page by having some show side by side. This is the page I'm working on but can't seem to figure out how to get rid of the border around each cell along with the white background. I'm using a pretty basic HTML table data cell method to accomplish this. Any ideas?

    http://galley6732.wpengine.com/california-dealers/

  2. Christian1012
    Member
    Posted 8 months ago #

    table{
       border:none;
    }
    table tr{
       background:#f5f5f5;
    }
    table td{
       border:none;
    }

    If you're customizing a theme, place this in the style.css file of your child theme.

  3. Evan Herman
    Member
    Posted 8 months ago #

    Add this to your CSS file

    table td {
     border: none;
     border-color: transparent;
    }
    
    table tr {
     background: transparent !important;
    }
    
    table {
     border: none !important;
    }
  4. Drew75
    Member
    Posted 8 months ago #

    Okay, I added that code to my themes style.css file and nothing changed.

  5. Evan Herman
    Member
    Posted 8 months ago #

    It should be. When I change code around in my inspector it seems to be removing what you need it to.

  6. Drew75
    Member
    Posted 8 months ago #

    Maybe I don't have the code entered on the actual page I'm working on correctly?

  7. Christian1012
    Member
    Posted 8 months ago #

    First you'll want to create a child theme using the link I posted above. Then in your child theme's style.css file, paste the code posted above.

    I just searched the stylesheet you're using, and the code provided wasn't found there. So you either added it to the wrong file, or whatever method you used to update that file didn't work.

  8. Drew75
    Member
    Posted 8 months ago #

    I did that following the instructions on the page you provided above and when I activated the child theme in Appearance>Themes, my site looked all screwy, so I reactivated the parent Theme and then pasted the code you provided into the style.css file of that and it didn't take. I pasted it at the bottom of the code in style.css just before the last }.

  9. Drew75
    Member
    Posted 8 months ago #

    I updated the style.css file in my WP Dashboard in Appearance>Editor and have gone back to look and the code I added is still there.

  10. WPyogi
    Volunteer Moderator
    Posted 8 months ago #

    the child theme in Appearance>Themes, my site looked all screwy

    Child Themes don't carry over settings/options from the parent, so you'll need to redo those. But the theme style.css file has this note at the top of it:

    /* --- [ YOU SHOULD NOT CHANGE THIS FILE. Make style changes on the Theme Settings page or on custom.css ] --- */

    So try adding the CSS there.

  11. WPyogi
    Volunteer Moderator
    Posted 8 months ago #

    Just to clarify, you don't need a child theme since you're only changing CSS and your theme has custom CSS.

  12. Drew75
    Member
    Posted 8 months ago #

    That fixed it, thank you. :)

Reply

You must log in to post.

About this Topic