WordPress.org

Ready to get started?Download WordPress

Forums

Table 'chaosxl_wordpress.wp_post2cat' doesn't exist error when upgrading to 2.3 (2 posts)

  1. miCRoSCoPiCeaRthLinG
    Member
    Posted 6 years ago #

    Hi,
    I just upgraded to WP 2.3 from WP 2.2.3 and after performing the database upgrades, I keep getting this error right at the top of the page. The error message goes like:

    WordPress database error: [Table 'wordpress.wp_post2cat' doesn't exist]
    SELECT p2c.category_id AS cat_id, COUNT(p2c.rel_id) AS numposts, UNIX_TIMESTAMP(max(p.post_date_gmt)) + '0' AS last_post_date, UNIX_TIMESTAMP(max(p.post_date_gmt)) AS last_post_date_gmt FROM wp_post2cat p2c INNER JOIN wp_posts p ON p2c.post_id=p.id WHERE (p.post_status='publish' OR p.post_status='static') AND p.post_date_gmt<='2007-09-27 10:39:50' GROUP BY p2c.category_id ORDER BY numposts DESC

    I deactivated all my plug-ins and yet I keep getting this error on every single page. So it can't be related to a plug-in. Any idea how to fix this?

  2. MichaelH
    Member
    Posted 6 years ago #

    You likely have an incompatible plugin or theme.

    This thread has a discussion:
    http://wordpress.org/support/topic/135564?replies=41

Topic Closed

This topic has been closed to new replies.

About this Topic