WordPress.org

Ready to get started?Download WordPress

Forums

Table borders not showing anywhere on website (11 posts)

  1. Apexeon
    Member
    Posted 1 year ago #

    None of the tables I've added are parsing correctly (I can't see their borders). Not a big deal but

    Using minutes-agendas-newsletters plugin, that table also doesn't show up either.

    http://rancho.byethost17.com/?page_id=61

  2. WPyogi
    Volunteer Moderator
    Posted 1 year ago #

    No doubt because the reset.css gets rid of them all by default:

    table {
        border-collapse: collapse;
        border-spacing: 0;
    }
    
    html, body, div, span, applet, object, iframe, h1, h2, h3, h4, h5, h6, p, blockquote, pre, a, abbr, acronym, address, big, cite, code, del, dfn, em, font, img, ins, kbd, q, s, samp, small, strike, strong, tt, var, b, u, i, center, dl, dt, dd, ol, ul, li, fieldset, form, label, legend, table, caption, tbody, tfoot, thead, tr, th, td {
        background: none repeat scroll 0 0 transparent;
        border: 0 none;
        font-size: 100%;
        margin: 0;
        outline: 0 none;
        padding: 0;
        vertical-align: baseline;
    }

    You'll need to modify the CSS to add back what you want. Be sure to use a child theme or custom CSS option or plug-in so that your changes are not lost when you update the theme.

  3. WPyogi
    Volunteer Moderator
    Posted 1 year ago #

    Looks like you'll need to go to theme forest for any further help, though, as commercial themes are not supported here.

  4. Apexeon
    Member
    Posted 1 year ago #

    There's an option in the theme settings that reads>

    "Enable style.css
    Enable "style.css" Enable the style.css located in the theme's root folder. You can then edit that file from Appearance -> Edit to add any custom CSS. You would also need to enable this option if you want to use a child theme."

    Could I use this in some way? I enabled it. Style.css has comments only in editor.

  5. Apexeon
    Member
    Posted 1 year ago #

    I renamed the reset.css. It had no effect.

  6. WPyogi
    Volunteer Moderator
    Posted 1 year ago #

    Not sure what you mean by "renamed" but probably not a good idea. You would need to add something like this to your custom CSS stylesheet:

    table, td {
       border: 1px solid black;
    }

    Specifics would depend on the styles you want -- this is a good CSS reference site: http://www.w3schools.com/css/css_table.asp

    Also, as mentioned earlier, you really need to get help from theme forest -- as support is part of what you paid for with a commercial theme -- and there may be theme specific things that are relevant to what you are trying to do.

  7. Apexeon
    Member
    Posted 1 year ago #

    Yeah that did nothing.

  8. Apexeon
    Member
    Posted 1 year ago #

    Switched to the twenty Eleven theme. It doesn't look better. The outside borders are all missing. And twenty eleven is definitely a wordpress theme, so the problem is either not related to u0design or a combination of things.

  9. WPyogi
    Volunteer Moderator
    Posted 1 year ago #

    Since you are now in twentyeleven, be sure to create a child theme for any changes, and then look at this code re: tables:

    .entry-content table, .comment-content table {
        border-bottom: 1px solid #DDDDDD;
        margin: 0 0 1.625em;
        width: 100%;
    }
    
    table {
        border-collapse: separate;
        border-spacing: 0;
    }

    Copy the above to your child theme style.css file and change accordingly.

  10. WPyogi
    Volunteer Moderator
    Posted 1 year ago #

    I'd also suggest using Firebug to help you look at what CSS code is affecting elements on your page...

  11. Apexeon
    Member
    Posted 1 year ago #

    Thanks for the suggestions but this is a waste of time and I'm tired of banging my head against this problem for the last 4 hours.

Topic Closed

This topic has been closed to new replies.

About this Topic