WordPress.org

Ready to get started?Download WordPress

Forums

[resolved] table borders not right weaver 2010 (7 posts)

  1. applesfaceman
    Member
    Posted 3 years ago #

    Hi, I would like to simply make it so, as i specify table properties through html, in the post, that the table takes on what i have in the html in the post, right now i insert

    <table width="57%" border="0" cellspacing="0" cellpadding="0">
      <tr>
        <td>&nbsp;</td>
        <td>&nbsp;</td>
      </tr>
    </table>

    and i get a white border around the whole thing, and when i put content in the tables, there stretched out all over.. and crazy, could i edit something so what ever i specify, is what the tables do? without messing up any tables used in the theme itself?

  2. AARONDAS
    Member
    Posted 3 years ago #

    This is what I did, go into 2010style.css, and go to #content tr td. In there you will find a style "padding: 6px 24px;", either comment it out or delete it then save it and presto!

    Thanks,

    Aaron

  3. applesfaceman
    Member
    Posted 3 years ago #

    Thanks AArondas!

  4. Raffael Fischer
    Member
    Posted 3 years ago #

    Does anyone know how you get rid of the borders (and other pre-settings) when using HTML tables in the theme "2010 Weaver"??? I just can't get them away. I only found some entrys in the stylesheet-file 2010style.css

    #content table {
    border: 1px solid #e7e7e7;
    margin: 0 -1px 24px 0;
    text-align: left;
    width: 100%;

    Changing the values to doesn't help. The borders stay.

    #content table {
    border: 0px solid #ffffff;
    margin: 0 -1px 24px 0;
    text-align: left;
    width: 100%;

    Even using the white color doesn't help. The borders resist! Where do they come from?

    In the post I can write:

    <table style="border: solid 2px #ffffff;" align="left">
    <tbody>
    <tr>
    <td style="border: solid 2px #ffffff;" width="35%" valign="top">xx</td>

    That's so far the only way that works. But it's ugly and stupid to have to make every single td invisble.

    Can anyone help me? I'm searching since hours for the solution. Didn't find it so far. Thank you.

  5. wpweaver
    Member
    Posted 3 years ago #

    There's a whole section on tables in the snippets tab of the Weaver admin interface.

    And the new Weaver 1.5 has several alternate table styles.

  6. nbruley
    Member
    Posted 3 years ago #

    The following code in my header <style> worked for me. (You don't need all this, just the border:none parts)

    #content table {border: none; margin: 0 -1px 24px 0;text-align: left;width: 100%;}
    #content tr th,#content thead th {border: none; color: #000000;font-size: 14px;font-weight: bold;line-height: 18px;padding: 2px 24px; background-color:transparent;}
    #content tr td {border-style:none; border-top: 0px; padding: 2px 24px;}
    #content tr.odd td {background: none;}

  7. wdews
    Member
    Posted 3 years ago #

    The creator of Weaver replied before you, nbruley. I had this same trouble before, even went into the blanket .CSS files hidden deep within my directories and changed the border settings for tables and "td" parameters. This fixed the issue temporarily, but as listed in the actual document I edited, it was noted that these settings are dynamically changed on a constant basis.

    With this in mind, I figured that the only thing that could truly affect this was some sort of set of rules that would continue to be referenced. *Lightbulb* "Oh yeah, the Weaver Admin" interface. Went in here, did a Ctrl+F and searched for Table or Border and found what I was looking for. Try it, it'll save your life.

Topic Closed

This topic has been closed to new replies.

About this Topic

Tags

No tags yet.