WordPress.org

Ready to get started?Download WordPress

Forums

[resolved] Tabbing between Title/Caption on Add Media screen not working (3 posts)

  1. Michelle
    Member
    Posted 1 year ago #

    I'm on 3.5-RC2-22928.

    I create a new post/page, click to upload media, add an image, then highlight the image Title (original file name) and type something new. Without moving away I hit 'tab' to get to the Caption field and the focus goes... somewhere else. Tabbing again brings the focus to 'delete permanently' then back to Title, then to Caption.

    This is only broken the first time I try to edit the Title field; once it's edited the focus moves correctly from Title to Caption.

    (Also, and this is more of a nit than a bug, it's sorta weird to me that the default content of the Title field is editable, but the default 'caption' content "Describe this image..." isn't, yet doesn't disappear when you click in the field. I think the default text for the Caption should disappear on focus, rather than when the user starts typing... just me?)

  2. Confirmed and reported on trac: https://core.trac.wordpress.org/ticket/22659

    think the default text for the Caption should disappear on focus, rather than when the user starts typing... just me?)

    That's how HTML5's placeholder attribute works.

  3. Michelle
    Member
    Posted 1 year ago #

    That's how HTML5′s placeholder attribute works.

    Didn't know that - thanks!

Topic Closed

This topic has been closed to new replies.

About this Topic