WordPress.org

Ready to get started?Download WordPress

Forums

Tabbed Widgets picky with 2.8? (59 posts)

  1. MattAlgren
    Member
    Posted 5 years ago #

    Since I upgraded to WordPress 2.8 this morning, the plugin's been picky with some widgets. It seems to hate text widgets, the calendar, archive...

    It's also hating the disqus widget, which is just a text widget with js in it.

    Any fix in the works?

  2. Peccator
    Member
    Posted 5 years ago #

    Upgraded to 2.8 and all my tabs went away (they are all expanded at the same time). They worked perfectly prior to the upgrade.

  3. Oeffi
    Member
    Posted 5 years ago #

    I upgrade from WP2.7.1 to 2.8 and now the Tabbed Widget 0.77 doesn't work in the frontend. The backend is ok.

    I see only one tab and the other 3 tabs are gone.

  4. alsd
    Member
    Posted 5 years ago #

    Having the same problem. Upgrade to v2.8 breaks the frontend.

  5. Kaspars
    Member
    Posted 5 years ago #

    Hey, All. I am aware of the problem and a new version is in the works.

  6. Oeffi
    Member
    Posted 5 years ago #

    Hey, All. I am aware of the problem and a new version is in the works.

    Thats fine, because it's a great widget

  7. jflash97
    Member
    Posted 5 years ago #

    Love this widget, but having it not work after upgrading to 2.8 made me discover it was adding 3 to 4 seconds of load time.

  8. MattAlgren
    Member
    Posted 5 years ago #

    Thanks for the update, kaspars! I appreciate your work on this one!

  9. Oeffi
    Member
    Posted 5 years ago #

    Thanks for the update, kaspars! I appreciate your work on this one!

    Which update do you mean, the update in the future for the wp2.8 BUG? Or is there a new update to download?

  10. manaschuen
    Member
    Posted 5 years ago #

    Also waiting here.
    It's my favorite widget, Kasparsd, thanks for your great work.

    When I know that your widget doesn't work with 2.8 I just said to myself that I should not have upgraded my WP version.

  11. siutouamy
    Member
    Posted 5 years ago #

    does it make it look like this?

    I just noticed it acts weird when I get inside a post, but looks normal when I'm on the front page. O.o

  12. seeal
    Member
    Posted 5 years ago #

    is fixed? :s I'm need this great plug-in

  13. ArnyVee
    Member
    Posted 5 years ago #

    I'm starting a new WordPress site and I need a tabbed widget like this. Any estimated time on when you'll be done with the upgrade on this great plugin kaspardsd?

  14. wendymerritt
    Member
    Posted 5 years ago #

    Help! Is the update almost ready? My tabs aren't working and all the items are expanded in my sidebar. I love this plugin :-)

    Blessings,
    Wendy

  15. ArnyVee
    Member
    Posted 5 years ago #

    I sure hope so Wendy. I'd love to have an option like this for my new site :D

  16. Pootmatoot
    Member
    Posted 5 years ago #

    Are there any functionally similar widgets while we wait for an update?

  17. alsd
    Member
    Posted 5 years ago #

    I was going to make a donation for this widget when I started implementing it to v2.7 and when the site launches. But didn't have a change to use it just yet as like many of you, I upgraded the site to v2.8 when it was still under development and the widget no longer works.

    This is a great widget, and obviously many of you who are waiting for the new release love to continue using it. Therefor, I would like to make a proposal that why don't we each make a contribute to kasparsd, so that he can have the luxury to spare a bit of time to make this widget compatible with v2.8 sooner. I would have gone ahead sending a donation to kasparsd, but I don't think my own effort help much to speed up the developmentā€“being a web designer myself, I know how much time it can take for a programming work like this, therefor I think it will be greatly helpful if all of you waiting for the widget can help pool up a fund.

    I was going to donate US$25 initially, but I am going to top it to US$40. Please join me everyone. And to kasparsd, if you see this message, can you tell us if this is workable for you to make the widget works in v2.8 sooner?

    thanks

  18. wolverine7
    Member
    Posted 5 years ago #

    I have been working on this damn thing for over 2 weeks now. I have uploaded 4 different widgets using my Filezilla to my hostgator epanal and can't find anything anywhere. I have not been able to get any widgets onto my blog. I started out with the 2.8 and after reading all of the other post, I'm about ready to dump this whole thing in the trash and go back to google blog. I have had to do all of my links as a post on my front page just so I could get it up to advertize with. I have lost over three weeks of advertizing in my marketing and only have a couple of weeks left before I lose everythine, I have been out of work for 5 weeks now and this was my last hope of bringing in some income. Is it possable to go back to the 2.6.3 like I was suppose to start with??

  19. Kaspars
    Member
    Posted 5 years ago #

    alsd, this would sure help a lot. Every donation counts and moves things higher in the priority list.

    I also appreciate you encouraging others to support the development of this Free Software.

  20. Kaspars
    Member
    Posted 5 years ago #

    wolverine7, with WordPress you don't have to upload widgets to the server. Check the Appearance > Widgets section of your WordPress admin area.

  21. alsd
    Member
    Posted 5 years ago #

    Hi, kasparsd. I sent 30 euro. I hope you have already received contribution from other who love to continue using this widget. :)

  22. onkelandy
    Member
    Posted 5 years ago #

    Hi all! Somehow weird.. I don't have problems in the frontend but on the site itself. Since WordPress 2.8 I can't show tabs anymore (newest jquery used). I get the message:

    $.widget is not a function
    (?)()(function())ui.tabs....ver=1.7.1 (Linie 608)
    ui.tabs.js?ver=1.7.1()()ui.tabs....ver=1.7.1 (Linie 685)
    $tw(this).find(".tw-rotate .tw-nav-list").tabs is not a function
    [Break on this error] fx: { opacity: 'toggle', duration: 'fast' }
  23. ArnyVee
    Member
    Posted 4 years ago #

    So, no fix for 2.8 as of yet?

  24. chmura
    Member
    Posted 4 years ago #

    Any updates on this?

  25. crz
    Member
    Posted 4 years ago #

    Looking forward for an update on this one :)

    Regards.

  26. Roger Theriault
    Member
    Posted 4 years ago #

    The tabs issue is described here:

    http://comox.textdrive.com/pipermail/wp-hackers/2009-June/026680.html

    Essentially, for WP 2.8, where you used to have

    jQuery('#foo > ul').tabs();

    you now need

    jQuery('#foo').tabs();

    (provided you're loading the jquery and ui.tabs that come with WordPress)

  27. mohanbn
    Member
    Posted 4 years ago #

    Sorry, i didn't get your solution. Could you explain it a bit more? how can we get this tabbed-widget plugin to work?

  28. Tosh
    Member
    Posted 4 years ago #

    I came across this today. It's the best looking one it seems. This would work perfect for me. On your fix Roger, I can't find that code in the plugin.

  29. r-a-y
    Member
    Posted 4 years ago #

    Roger's post doesn't mean anything. That's just a small jQuery issue.

    The larger issue at hand with WP 2.8+ is the entire widget API has changed.

    So a lot of kaspars' code will need to be rewritten in order for Tabbed Widgets to work on 2.8+.

  30. btlewand
    Member
    Posted 4 years ago #

    Hey kasparsd,

    Any ETA on the 2.8 version of Tabbed Widgets? Not upgrading to 2.8 until the update is available and tested. Thanks. You have an excellent plug-in.

Topic Closed

This topic has been closed to new replies.

About this Topic