WordPress.org

Ready to get started?Download WordPress

Forums

Duplicator
[resolved] System req all pass, but test connection fails on WAMP (6 posts)

  1. misksh
    Member
    Posted 12 months ago #

    I'm using WAMP to recreate my web site that exist on my web server.
    http://backcountryreporter.info/

    I installed the plugin, created and downloaded the packages to a folder called wp1 in my WAMP www directory.

    I brought up the "installer.php" file in http://localhost:8080/wp1/installer.php.

    I filled out the Host as "localhost:8080", User as "root", Password as blank, Database name as "bcr1".

    Allow Options are "Database Creation" checked, "Table Removal" unchecked.

    I clicked on "Sytem Requirments: Pass..." and see that everything passes.
    ***************text************************

    Root DirectoryPass
    Path: C:\wamp\www\wp1
    [Pass] Is Writable by PHP
    [Pass] Contains only one zip file
    Result = 51f889434ead18177_20130731_backcountryreporter_package.zip
    Note: Manual extraction still requires the package.zip file

    Safe Mode OffPass
    MySQL SupportPass
    PHP Version: 5.4.12
    (PHP 5.2.17+ is required) Pass

    CHECKS
    Web Server: Apache Good
    Open Base Dir: Off Good
    PHP SAPI: apache2handler
    PHP ZIP Archive: Is Installed
    ****************text********************

    I clicked on the "Test Connection..." and get an error.
    ********error text*********
    An error occurred while testing the database connection! Be sure the install file and the package are both in the same directory.
    ********error text**********

    Both the installer.php and the zip file are in the same directory.

    What is the problem?

    Thanks,
    Ken

    http://wordpress.org/plugins/duplicator/

  2. Cory Lamle
    Member
    Plugin Author

    Posted 12 months ago #

    Hey misksh,

    If you can give the Developer Version a try it may have your fixes for the issue you're seeing. The very latest version can be found by following these instructions:

    -> Browse to http://wordpress.org/extend/plugins/duplicator/developers/
    -> Look for the section "Other Versions"
    -> Click on "Development Version" and download the zip plugin file
    -> Uninstall your current version and install this one
    -> Note: The version number might still be the same but the source code is different.

    Let me know if that helps...

  3. misksh
    Member
    Posted 12 months ago #

    Yes, the "Developer Version" worked for the most part. There are only 2 minor problems. There is a warning on for the "wp-config.php" file reading:
    *************************
    GENERAL WARNINGS
    The following is a list of warnings that may need to be fixed in order to finalize your setup.
    WP-CONFIG WARNING: The wp-config.php has one or more of these values "WP_CONTENT_DIR, WP_CONTENT_URL, WPCACHEHOME, COOKIE_DOMAIN, WP_SITEURL, WP_HOME, WP_TEMP_DIR" which may cause issues please validate these values by opening the file.
    *************************
    The "wp-config.php" lines that may be causing the problem are:

    On the localhost:
    define('WP_CACHE', false); //Added by WP-Cache Manager
    define( 'WPCACHEHOME', '' ); //Added by WP-Cache Manager

    On the web server:
    define('WP_CACHE', true); //Added by WP-Cache Manager
    define( 'WPCACHEHOME', '/hermes/waloraweb067/b2276/moo.kenshoufercom/backcountryreporter/wp-content/plugins/wp-super-cache/' ); //Added by WP-Cache Manager

    Maybe I should just comment out these lines.

    The other problem has to do with an error message I get while in the wp-admin page. It reads:
    **************************************
    Warning: call_user_func_array() expects parameter 1 to be a valid callback, function 'wptrcd_rbams' not found or invalid function name in C:\wamp\www\bcr2\wp-includes\plugin.php on line 406
    Call Stack
    # Time Memory Function Location
    1 0.0057 422248 {main}( ) ..\plugins.php:0
    2 1.0507 31800208 require_once( 'C:\wamp\www\bcr2\wp-admin\admin-header.php' ) ..\plugins.php:362
    3 1.1091 31828312 do_action( ) ..\admin-header.php:69
    4 1.1093 31830232 call_user_func_array ( ) ..\plugin.php:406
    *************************************

    This might have to do with the same problem. Maybe one of my plugins is having a problem.

    Ken

  4. Cory Lamle
    Member
    Plugin Author

    Posted 12 months ago #

    Hey Ken,

    Usually the most effective solution is to re-enable your cache plugins and then resave the settings and those values will be updated at the new server location.

    If that fixes the errors then you should be good to go, if you are on a development box I would go back and disable any cache plugins after getting the warning/error messages to dismiss as cache plugins can cause issues with testing...

  5. misksh
    Member
    Posted 12 months ago #

    I deactivated and reactivated all my plugins, but that didn't work.

    I did have success when I deleted and reloaded my "WP ToolBar Removal" plugin. There must have been a bug in it.

    Thanks for the advice.

  6. Cory Lamle
    Member
    Plugin Author

    Posted 12 months ago #

    Excellent! Thanks for posting your fix...

Reply

You must log in to post.

About this Plugin

About this Topic