WordPress.org

Ready to get started?Download WordPress

Forums

[closed] Syntax Error when Activating Plugins But Yet They Are Active? (4 posts)

  1. jrothra
    Member
    Posted 2 years ago #

    After looking for the right plugin via the Dashboard, verify that it's been tested and is compatible, I click "Install now." It installs fine. Then I click "Activate plugin." At this point I get the following error from the database:

    You have an error in your SQL syntax; check the manual that corresponds to your MySQL server version for the right syntax to use near 'TYPE=MyISAM' at line 9 on line: 1471

    I have no idea what that means. I click back in my browser, then go to the plugins page. There I see the plugin I just installed/tried to activate is active. What is causing this?

  2. zimmi88
    Member
    Posted 2 years ago #

    One of the technologies WordPress uses to run is MySQL, a database system. Broadly speaking, a database is a giant collection of organized data, which, in the case of WordPress, it uses to store information about your site, like posts, comments, settings, users, et cetera.

    That error likely means the plugin you activated had some MySQL queries (commands to save or retrieve data from a database) it tried to run but was unable to... there was an error in how the query was written such that the MySQL engine was unable to understand what it was saying.

    As for the plugin... well, if it appears to be working as expected, awesome. However, if the plugin is expecting to use a table that, due to this error, may not exist, it might run into issues. If this is the case, I'd recommend disabling it for now and either posting in the appropriate plugin forum to see if anyone else is having this issue or, if the plugin author has included contact info, you can try contacting the plugin author directly to let them know of the issue.

    I hope this helps!

  3. NormanBird
    Member
    Posted 1 year ago #

    I too am having this issue of late and it seems to not be one plugin , as its happening now whenever I install ANY plugin. It installs , no problem, upon activation, i get the error, backspace to plugin page and all is well. No idea what is wrong and where.

    appears to be maybe something core, or DB related error. Anyone seen this before and solved it?

  4. Andrew
    Forum Moderator
    Posted 1 year ago #

    Sorry NormanBird, you'll have to create your own thread on the issue.

Topic Closed

This topic has been closed to new replies.

About this Topic

Tags

No tags yet.