WordPress.org

Ready to get started?Download WordPress

Forums

Switching Windows to Linux server caused warning errors at Godaddy (5 posts)

  1. bimod
    Member
    Posted 2 years ago #

    The site started with ASP so we had the Window server. After the WordPress site started I noticed some sluggishness and then had permission errors when we tried to upload image files. Godaddy support recommended server switch to Linux, and they did. I didn't have to do anything. But now on the footer area, the errors show. See the errors at the bottom in double quotes.

    When contacted back, Godaddy told me to upgrade the WP, so I did yesterday but still showing the same errors on every page. They told me to give time till Sunday. I don't see why and bet it will persist.

    I have no clue how to go about. "Line 0"? Anybody has any suggestion? What file even should I look into not that I can understand enough to fix it probably?

    I backed up the database before the upgrade but not before the server switch. Do I need to uninstall and reinstall everything? If so, which stage database should I use? I'm not sure if Godaddy made a back-up before the server swap.

    Thank you in advance for any help I get.

    "Warning: Unknown: open(/var/chroot/home/content/21/8160721/tmp/sess_6ptnp309n8vl93jm96f5hcf163, O_RDWR) failed: No such file or directory (2) in Unknown on line 0"

    "Warning: Unknown: Failed to write session data (files). Please verify that the current setting of session.save_path is correct () in Unknown on line 0"

  2. esmi
    Forum Moderator
    Posted 2 years ago #

    That's a server issue. Contact GoDaddy.

  3. Nikki Blight
    Member
    Posted 2 years ago #

    Just to elaborate, your server/PHP is misconfigured and not handling PHP sessions correctly. Either you have no /tmp directory for PHP's session files, or PHP doesn't have permission to write to it's /tmp directory.

    Like esmi said, this is something GoDaddy needs to fix on their end, as it's not WordPress that's causing the problem, and you probably don't have the level of access required to fix it yourself.

  4. bimod
    Member
    Posted 2 years ago #

    Thank you both for giving me a direction!!

  5. bimod
    Member
    Posted 2 years ago #

    Contacted Godaddy. Sounding much more technical, I could convince a rep (my third) to look further. /tmp is created when WP is installed. But when the site was transferred to Linux from Windows, /tmp was somehow got lost and didn't get moved over. Also, WP was not installed but transferred to Linux, so it didn't get generated on Linux server automatically; thus, causing that issue.

    esmi and nionae were absolutely right and Godaddy had to go in to this shared server to created /tmp directory.

    So if the same need were ever to arise, I now know to migrate onto the Linux server first and then install WP.

    I'm documenting so others can benefit.

    Thank you so much!!!

Topic Closed

This topic has been closed to new replies.

About this Topic

Tags