WordPress.org

Ready to get started?Download WordPress

Forums

[resolved] Switching Servers/Importing Database issues. (5 posts)

  1. martynwithay
    Member
    Posted 5 years ago #

    I am trying to move my blog from GoDaddy's free hosting to Webhostingpad. This is easier said than done, as I am finding out right now.

    I used online tutorials to get to the point where I have all my old wordpress files uploaded to the new server, along with all the necessary changes to the config.php file. I also downloaded/backed up my old SQL database.

    Apparently, now I am supposed to import the old database. I use myphpadmin and go through the necessary steps, but I am left with this message:

    Error
    SQL query:
    --
    -- Database: journalcomic
    --
    CREATE DATABASE journalcomic DEFAULT CHARACTER SET utf8 COLLATE utf8_general_ci;
    MySQL said: Documentation
    #1044 - Access denied for user 'anotherj'@'localhost' to database 'journalcomic'

    Since my new site is hosted by WebHostingPad, my new database is named "anotherj_JournalComic" and there is no (advisable) way to remove the "anotherj_" from the beginning of the database name.

    Any ideas?

  2. figaro
    Member
    Posted 5 years ago #

    Create the database on your new host, then remove the CREATE DATABASE code from the .sql file. That way you are only creating tables and importing the data into your already created db.

  3. martynwithay
    Member
    Posted 5 years ago #

    It worked... It worked!!!
    I've spent all day on this and now it works!!!

    I love you! Thank you so much for helping me!

  4. Hoodedmonkey
    Member
    Posted 4 years ago #

    Hi Figaro!

    You also helped me by your post as removing "Create Database" has been enough to get my blog working exactly as it was before.

    I also had an extra step that I had to figure out that I thought I should share for anyone else that stumbles on this thread.

    At the very top part of your Database File when you open it in a notepad there are 3 instances where you will see your database name. If you have had to change servers the new database that you have created will most likely have a different name so you will also need to change the database name within the file along with removing "Create Database"

    I hope this helps somebody

    Peace.

  5. finallyanime
    Member
    Posted 4 years ago #

    This MIGHT be a bit more helpful:

    Actually, I got the exact same message & decided to go a different route.

    1. Looking at the options in the SQL Manager, you can "restore" an SQL file via the db_backup folder located in your starting location of the file manager.
    2. Just upload your SQL file to the backup folder, then goto the PHPMYADMIN and create a new database if you haven't already.
    3. Get out of PHPMYADMIN & when you're able to (might take time for godaddy to notice the new database), select the pencil icon next to the one you made
    4. Select restore, then select your SQL file.

    The above might sound convoluted, but it was VERY simple. You don't have to go into your SQL file and do anything :)

    HOWEVER it would be nice if you all or anyone could provide a list of the files/other changes needed for your site to work on godaddy...because I can't find any anywhere.

Topic Closed

This topic has been closed to new replies.

About this Topic