WordPress.org

Ready to get started?Download WordPress

Forums

[resolved] Switched servers. Main page works, but nothing else. Subdirectories?? (10 posts)

  1. thedayofgames
    Member
    Posted 4 years ago #

    I previously used Network Solutions. I am switching servers so I dragged over (via FTP) all of the files within my "blog" folder. All the files were then uploaded to my new server.

    Where are all the subdirectories??

    The main page works but it looks like none of the subdirectories are in there?

    http://www.thedayofgames.com/dogblog/

  2. MichaelH
    Member
    Posted 4 years ago #

    May need to update your permalinks via Admin->Settings->Permalink

    Also may look at using http://wordpress.org/extend/plugins/search-and-replace/ if you changed your domain (including the WordPress folder (e.g. old was blog, new is dogblog).

  3. thedayofgames
    Member
    Posted 4 years ago #

    Michael - Thank you for the reply.

    I am in the Admin->Settings->Permalink section and there isn't an option to update anything. I only see Common Setting and Optional.

    As you can see from my Blog... nothing works outside of the main page. My tech person is telling me that the Index is referencing subdirectories that do not exist. Am I missing a ton of folders? Where is all of this information?

    Here is some more background info:
    I was on Network Solutions. All info was stored in a folder called dogblog. I have now moved the entire folder over to a private server. The person setting up the server has been able to get the main page working but doesn't know how permalinks work so we need some guidance.

    How do I get the rest of the site working? Which step-by-step tutorial should I be reviewing?

  4. thedayofgames
    Member
    Posted 4 years ago #

    Got it working!

    I just moved the permalinks to DEFAULT.

  5. thedayofgames
    Member
    Posted 4 years ago #

    So one more question here...

    It works under Default but all of my URL names are now different. So I need to switch it back to "Day and Name"

    I cut and pasted the text into the htaccess file and then uploaded that to the server.

    The Permalinks still do not work.

    Any ideas?

  6. Gerald
    Member
    Posted 4 years ago #

    Hmm.. does your new server support mod_rewrite?

    You need it enabled to use permalinks.

    You aren't missing any folders. WordPress uses the apache rewriting module to map the URL to the corresponding post id in your blog. Even though you get http://example.com/blog/archive/2009, there are no folders named archive or 2009.

    About Permalinks:
    http://codex.wordpress.org/Using_Permalinks
    About Mod_rewrite:
    http://httpd.apache.org/docs/2.0/mod/mod_rewrite.html

  7. thedayofgames
    Member
    Posted 4 years ago #

    I have no clue. Let's assume it doesn't.

    Why would the permalinks continue to work under "Default" but not any of the other settings?

    I have uploaded the .htaccess file correctly and WordPress still tells me I should "You should update your .htaccess now."

    If this is a "mod_rewrite" issue, what exactly do I need to do? I don't have access to my server security, etc. I can upload and revise files though. What do I need to change in order for mod_rewrite to work?

  8. thedayofgames
    Member
    Posted 4 years ago #

    I just had both .htaccess and index.php file permissions changed.

    WordPress doesn't tell me there are any Permalinks issues... but it still doesn't work?

    I am no longer told this ""You should update your .htaccess now."

    It just says my Permalinks structure has been updated.

    But nothint but the main page works.

  9. thedayofgames
    Member
    Posted 4 years ago #

    Fixed -

    Modify the Permalink code to "Custom" and add /index.php/ to the front

    ----------------------------------------------------------------
    If this isn't an option, you can try PATHINFO permalinks; put index.php/ at the start of your custom permalink structure:

    /index.php/%year%/%monthnum%/%day%/%postname%/
    --------------------------------------------------------------------

  10. Gerald
    Member
    Posted 4 years ago #

    From the above, it would seem like mod_rewrite isn't enabled/installed Most of the time such problem occurs when you are on a Windows host.

    If you're on a linux hosting, you can write to your hosting provider and check if the Apache mod_rewrite module is enabled. If not, request it to be enabled.

    If your on Windows, than its abit more complicated. You can request your web host to install the rewrite IIS module but there are some configurations that you need to do as well on top of that as well. I am unsure of the specifics of the Windows rewrite module though.

Topic Closed

This topic has been closed to new replies.

About this Topic