WordPress.org

Ready to get started?Download WordPress

Forums

CSV 2 POST
Switch To PHP 5.3 Upwards Please (4 posts)

  1. WebTechGlobal
    Member
    Plugin Author

    Posted 1 year ago #

    Please do not ignore the notice that clearly states PHP 5.2 is not suitable for this plugin. We are finding a lot of users ignore the notice and proceed to use the plugin.

    PHP 5.3 is more reliable and 5.5 has been released with many fixes. WordPress itself has functions for 5.3 which operate better than their depreciated versions for PHP 5.2 so its not all about this plugin.

    Right now there are few reasons not to use 5.3 with a new WordPress installation or a WP 3.6 update but if you do have a reason you must not use our plugin.

    You can switch PHP versions using hosting control panel. Look for an icon named something like "Configure PHP" or "PHP Config" or "PHP Setup" etc.

    http://wordpress.org/plugins/csv-2-post/

  2. WebTechGlobal
    Member
    Plugin Author

    Posted 1 year ago #

    I just stumbled across the date which PHP 5.3 was released.

    "php5.3 was relased on 30-Jun-2009".

    Around 2011 most developers recommended 5.3 and it won't be long until 5.5 is recommended. I'm stating this due to how many people seem to be reluctant to upgrade. Maybe this is due to past PHP nightmares however these recent versions bring a lot of fixes and are better for development.

  3. Ryan Bayne
    Member
    Posted 11 months ago #

    Latest from phpBB development...

    The PHP development team announces the immediate availability of PHP 5.5.4. This release fixes several bugs against PHP 5.5.3. All PHP users are encouraged to upgrade to this new version.

    That was today. I seriously question hosting who default to PHP 5.2 as I have seen recently.

  4. WebTechGlobal
    Member
    Plugin Author

    Posted 1 month ago #

    "The PHP development team announces the immediate availability of PHP 5.4.30. Over 20 bugs were fixed in this release, including the following security issues: CVE-2014-3981, CVE-2014-0207, CVE-2014-3478, CVE-2014-3479, CVE-2014-3480, CVE-2014-3487, CVE-2014-4049, CVE-2014-3515. All PHP 5.4 users are encouraged to upgrade to this version.

    Please, note that this release also fixes a backward compatibility issue that has been detected in the PHP 5.4.29 release. Still, the fix in PHP 5.4.30 may break some very rare situations. As this tiny compatibility break involves security, and as security is our primary concern, we had to fix it. This concerns bug 67072. For more information about this bug and its actual resolution, please refer to our upgrading guide, section 4a. We apologize for any inconvenience you may have experienced with this behavior."

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic

Tags

No tags yet.