WordPress.org

Ready to get started?Download WordPress

Forums

Swedish language (12 posts)

  1. jea
    Member
    Posted 9 years ago #

    I do not manage to shift language to Swedish, and I cant see where I get lost.
    Did any of you out there successfully changed to Swedish, and if, what's your secret
    Har någon av er lyckats med att installera svenska som språk, och hur i all världen bar ni er då åt???

  2. Class
    Member
    Posted 9 years ago #

    Did you find the Swedish language file?
    Upload it to wp-includes\languages?
    Set the define ('WPLANG', 'se_SE'); (might not be correct syntax for Swedish) in wp-config.php?

  3. Mark (podz)
    Support Maven
    Posted 9 years ago #

    http://wordpress.org/support/topic/40023

    I can't see what has gone wrong with what should happen.

  4. jea
    Member
    Posted 9 years ago #

    podz:
    "Did you find the Swedish language file?
    Upload it to wp-includes\languages?"

    Yes, I found the file. But what exactly should the name of the file be in wp-includes\languages?

  5. Class
    Member
    Posted 9 years ago #

    jea: one post per topic please :)
    Check your other thread.

  6. jea
    Member
    Posted 9 years ago #

    I did check it out carefully, but it did not help much. And it seems like I am not the only one having this problem.

  7. jea
    Member
    Posted 9 years ago #

    Obviously WordPress does not support Swedish, and obviously WordPress documentation and experteese is wrong.
    Trying something else!

  8. [Moderated due to offensive content]

  9. Mark (podz)
    Support Maven
    Posted 9 years ago #

    If you come back......this works:

    // Change this to localize WordPress. A corresponding MO file for the
    // chosen language must be installed to wp-includes/languages.
    // For example, install de.mo to wp-includes/languages and set WPLANG to 'de'
    // to enable German lanuage support.
    define ('WPLANG', 'sv');

    /* Stop editing */

    and the file
    /wp-includes/languages/sv.mo

    It's the same advice as I gave here:
    http://wordpress.org/support/topic/40023#post-225146

    so all I can guess at now is that the theme you have is not correctly written to accept localisation.

  10. Offensive content? I honestly wasn't being offensive. Well, except for the badly translated Swedish part. Anywho, here's the original (and slightly truncated) version:

    We apologize for not having any officially supported Swedish content. But, as a volunteer-based free blogging platform, we lack both the money and time to afford and attend a suitable course in Swedish translation. Until then, all we can offer is the support here (in English) and these two articles:

    http://codex.wordpress.org/WordPress_in_Your_Language#Swedish

    http://codex.wordpress.org/Installing_WordPress_in_Your_Language

  11. malesca
    Member
    Posted 9 years ago #

  12. moshu
    Member
    Posted 9 years ago #

    It should be made clear that the modification in the config file should always follow the exact name of the .mo file (without the extension). Or - as an alternative - the .mo file should be re-named to what you put into the config file. E.g. if the .mo file is sv_SE.ISO-8859-1.mo you have to put in the config file exactly
    sv_SE.ISO-8859-1; and if the file is named sv.mo - the config file will have sv etc.

Topic Closed

This topic has been closed to new replies.

About this Topic