WordPress.org

Ready to get started?Download WordPress

Forums

NextScripts: Social Networks Auto-Poster
[resolved] %SURL% no longer being included in posts to Twitter (20 posts)

  1. cconstantine
    Member
    Posted 1 year ago #

    This was working, but -- I think -- when I updated to the latest SNAP version, it seems to have stopped.

    I have several sites using this. Eg two twitter feeds @KinokawaAikido and @lvknk On seems to have gone back to showing the full URLs and the other isn't showing any link at all.

    My "message text format" is "%TITLE%: %EXCERPT% %SURL%". I'm using Bitly as the URL shortener.

    http://wordpress.org/extend/plugins/social-networks-auto-poster-facebook-twitter-g/

  2. TheHutt
    Member
    Posted 1 year ago #

    Same here: the SURL parameter stopped working on my setup. Very strange, this.

  3. WPChina
    Member
    Posted 1 year ago #

    Yes same for me too but for the URL parameter. I posted the problem here:
    http://wordpress.org/support/topic/bug-when-ending-title-with-a-symbol-1?replies=4

    It stopped working on 6 different installations I manage 3 days ago.

  4. NextScripts
    Member
    Plugin Author

    Posted 1 year ago #

    Please contact support directly, we need to take a look at on of your sites.

  5. WPChina
    Member
    Posted 1 year ago #

    Ok will do

  6. JDO2010
    Member
    Posted 1 year ago #

    Has this been fixed? I am still getting an error.

    I am getting `Array ( [pgID] => [isPosted] => 0 [pDate] => 2013-03-26 09:39:59 [Error] => [ERROR](#100) link URL is not properly formatted
    )`

    Thanks,
    Jeremy

  7. cconstantine
    Member
    Posted 1 year ago #

    I just "reposted to twitter" using the newest 1.2.6 version... my %SURL% still is not appearing in the tweet.

  8. NextScripts
    Member
    Plugin Author

    Posted 1 year ago #

    Will be fixed in the next release.

  9. cconstantine
    Member
    Posted 1 year ago #

    woot. Thank you!

  10. NextScripts
    Member
    Plugin Author

    Posted 1 year ago #

    It's out. Please update to 2.7.7

  11. WPChina
    Member
    Posted 1 year ago #

    Awesome, thanks so much for your great service and responsiveness :)

  12. WPChina
    Member
    Posted 1 year ago #

    I get this error in the admin area when updating a post using the latest 2.7.7:

    Fatal error: Class 'nxs_class_SNAP_TW' not found in /www/website.com/wp-content/plugins/social-networks-auto-poster-facebook-twitter-g/inc-cl/tw.php on line 291

    It happened on another installation after I just upgraded to 2.7.7 and I refreshed and it disappeared and seemed to work fine. But on this second and third installs I get that error and refreshing seems to not make it disappear.

  13. NextScripts
    Member
    Plugin Author

    Posted 1 year ago #

    One of the files was missing from the upload. We just added it. Please re-download plugin.

  14. WPChina
    Member
    Posted 1 year ago #

    I just ran update wp_options set option_value='' where option_name='_site_transient_update_plugins'; on all databases and none of our sites are showing that the plugin has been updated yet

  15. NextScripts
    Member
    Plugin Author

    Posted 1 year ago #

    The corrected version is 2.7.8 - the update is available from the wordpress.org

  16. WPChina
    Member
    Posted 1 year ago #

    Great now when I run update wp_options set option_value='' where option_name='_site_transient_update_plugins'; on my WordPress installations it is accurately refreshing the cache and updating with 2.7.8 :)

  17. WPChina
    Member
    Posted 1 year ago #

    Ok 2.7.8 appears to fix the %URL% problem. I am testing it on multipel different installations and will have a full idea within 24 hours, but so far the tests are good :)

    Again many thanks for your responsiveness and great plugin. I moved all our client sites ot SNAP a few months ago after Social had problems. And in the coming months some of my clients will upgrade to your premium SNAP plugin too so I hope you can continue developing these plugins :)

  18. cconstantine
    Member
    Posted 1 year ago #

    %SURL% is working in tweets with 2.7.8.

    Thanks!

  19. justkristin
    Member
    Posted 1 year ago #

    I don't think it is resolved in 2.7.8 - I have updated but no SURL yet. I do get this error:

    [E] [-=ERROR=- WP_Error Object ( [errors] => Array ( [http_request_failed] => Array ( [0] => error setting certificate verify locations: CAfile: /etc/ssl/certs/ca-certificates.crt CApath: none ] -

  20. justkristin
    Member
    Posted 1 year ago #

    Hah! Nevermind. For some reason, my shortener went away (an upgrade, perhaps). I have re-entered API stuff and all is well.

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic

Tags