WordPress.org

Ready to get started?Download WordPress

Forums

UploadPlus : File Name Cleaner
[resolved] Support for UTF-8 characters non existing? (12 posts)

  1. marikamitsos
    Member
    Posted 1 year ago #

    Hi and thank you for your excellent work.

    We have tried it on websites with the latin characters and works out of the box. :)
    Still. When trying to use fnc on images like this one or this (that is the greek alphabet) all we get is underscores. Please have a look either by downloading the file and trying to upload it to the media library or saving the file using the Insert from URL or the Grab and Save plugin.
    It would be great if we could use it for NON-Latin characters (greek in our case).

    Can you please have a look?
    Thank you.

    http://wordpress.org/extend/plugins/uploadplus/

  2. swergroup
    Member
    Plugin Author

    Posted 1 year ago #

    Hi marikamitsos,
    seems that the utf8 library is causing some trouble, as it is supposed to work well in that scenario. We're looking to fix this in the next release but I can't estimate a release (yet).

  3. marikamitsos
    Member
    Posted 1 year ago #

    Thank you for the reply.
    Glad you pinpointed the problem.

    but I can't estimate a release (yet).

    Yesterday would be great. :)
    Well... All we can do is wait.
    Please let us know how we can help (testing/debugging).

    You have created a really unique plugin.
    Thanks once again.

  4. swergroup
    Member
    Plugin Author

    Posted 1 year ago #

    Next week perhaps? :-)

    Our chosen UTF8 library was really broken and we had to plan a new way to make it work. Thankfully, github and open source helps a lot these days, and we found great alternatives. By the way, your example files helped us a lot testing this one, thank you!

    If you're willing to help us testing here's our work in progress (it should be 3.1.2 now):

    https://dev.swergroup.com/wp-uploadplus/get/master.zip

    PLEASE NOTE: This is almost-untested code, don't rely on this release for production WPs!

  5. swergroup
    Member
    Plugin Author

    Posted 1 year ago #

    Nevermind: I was out of sync with the other guys, they have already released 3.2.1 and this should fix your issue. Let us know if this work!

  6. marikamitsos
    Member
    Posted 1 year ago #

    Works like a charm. Thank you so much. :)

    Still... There is something else I would like to ask you.
    We face problems with the encoding when it comes to the greek language. That is the reason why we always use this light, very old but still working plugin (right click to download the zip from our dropbox) which changes the greek alphabet to "greeklish".
    The plugin works great for posts, pages, tags, etc. But does nothing for files
    I wonder if there was a way to implement this functionality to your plugin. From what I understand you already do it for arabic characters.

    Thanks again.

    PS: Please feel free to mark as resolved. The only reason I haven't is as to draw your attention.

  7. swergroup
    Member
    Plugin Author

    Posted 1 year ago #

    Thank you for your explaination and the code, it's already in our development version; while we test, you can checkout the latest zip here:

    https://bitbucket.org/swergroup/wp-uploadplus/get/master.zip

    (it should be swergroup-wp-uploadplus-b6990f5ae278.zip ).

    If this works, we'll include in the next public version as well as other features.

  8. marikamitsos
    Member
    Posted 1 year ago #

    Ahhh... You're in my mind. :)
    Thank you. Just downloaded it.
    Will test it asap. Will have the results for you in a couple of hours.

  9. marikamitsos
    Member
    Posted 1 year ago #

    Hi again. After updating the plugin.
    The transliteration part works fine.

    There must be a bug though applying the prefix. It applies it twice.

  10. swergroup
    Member
    Plugin Author

    Posted 1 year ago #

    the double prefix bug is already fixed in dev, we'll release it in time for WP 3.6. We're just trying to avoid last minute bug again :)

  11. marikamitsos
    Member
    Posted 1 year ago #

    Big news.
    After your loooong silence you got me thinking wether it was just me having the issue.
    Thanks again. Great work. :)

  12. swergroup
    Member
    Plugin Author

    Posted 1 year ago #

    sorry for the late reply, I can't follow the forum as I would.
    if you like to follow dev news you can track our progress on GitHub :-)

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic

Tags

No tags yet.