WordPress.org

Ready to get started?Download WordPress

Forums

SuperCache's cache files permission problem (1 post)

  1. maestro4k
    Member
    Posted 6 years ago #

    I'm using version 0.5.1 of wp-supercache, and for some reason it creates all the supercache files (under wp-content/cache/supercache) with only read and write perms for owner. On my server I use suphp to run PHP files as the user, but the Apache server runs as its own user. If static files (like the supercache ones) don't have read privileges for world then the server won't serve them. I can't figure out why supercache would be doing this because it does create the directories with the correct permissions (read and execute for both group and world). I've checked everything, the user's umask is 0022, the web server's user's umask is also 0022 so it _should_ be creating them with the correct permissions. I've tried setting a cronjob to chmod the files every 5 minuts as a workaround but there are still too many errors so I had to disable supercache.

    Any idea on how to fix this? Help would be greatly appreciated. :)

Topic Closed

This topic has been closed to new replies.

About this Topic