WordPress.org

Ready to get started?Download WordPress

Forums

Supercache wp-content/cache/.htaccess Permission Denied (3 posts)

  1. thebiganswer
    Member
    Posted 2 years ago #

    Hi all,

    The WP Supercache plugin install notes suggested adding a .htaccess file to the wp-content/cache folder, which looks like this:

    # BEGIN supercache
    
    <IfModule mod_mime.c>
        <FilesMatch "\.html\.gz$">
            ForceType text/html
            FileETag None
        </FilesMatch> 
    
        AddEncoding gzip .gz
        AddType text/html .gz
    </IfModule> 
    
    <IfModule mod_deflate.c>
        SetEnvIfNoCase Request_URI \.gz$ no-gzip
    </IfModule> 
    
    <IfModule mod_headers.c>
        Header set Cache-Control 'max-age=300, must-revalidate'
    </IfModule> 
    
    <IfModule mod_expires.c>
        ExpiresActive On
        ExpiresByType text/html A300
    </IfModule>
    
    # END supercache

    (This controls expiration headers and also compression settings.)

    I uploaded this file to the wp-content/cache folder but in testing I wasn't certain this file was being processed correctly, so I wanted to remove it and/or modify it. Unfortunately I see this message in Filezilla (FTP client):

    550 CHMOD 666 .htaccess: Operation not permitted

    I was able to upload the file originally, so why am I now blocked from uploading/renaming/deleting this file? Changing permissions on the wp-content/cache folder is also denied.

    Is there something obvious I'm missing? Have I blocked myself through the various settings required by Supercache?

    Thanks

  2. Brad Markle
    Member
    Posted 2 years ago #

    Hi thebiganswer. How did you create the file originally? For example, did you use some type of file manager or did you upload the file with ftp?

    From my experience, I would say that this issue is due to file ownership. You can try contacting your web host and making sure your user has access to the file. For example, the file may be owned by "nobody" when instead it should be owned by you user.

  3. thebiganswer
    Member
    Posted 2 years ago #

    Hi Brad,

    Thanks for your reply. I uploaded using Filezilla after installing/configuring the WP Super Cache plugin. Your advice regarding 'nobody' permissions matches something I've read elsewhere so this may well be the way forward.

    I've just noticed that the WP Super Cache plugin has updated the file, so it appears to have sufficient permission of its own. (I wonder now whether I did in fact ever have permissions to upload the file - perhaps the .htaccess file was already there and I ignored the original 550 FTP error message.)

    I've verified that the compressing and expiration headers are working (Yslow Firefox plugin) so this may be a 'storm in a tea cup' after all. Still, I'll try to find out why I'm blocked.

    Thanks.

Topic Closed

This topic has been closed to new replies.

About this Topic