WordPress.org

Ready to get started?Download WordPress

Forums

SuperCache causes CGI/PHP overload? (6 posts)

  1. katmmad
    Member
    Posted 2 years ago #

    I've had this plugin deactivated forever after an incident (in April or so) where something caused my server to overload -- after I convinced my hosting company to let me into the backend, we turned off all plugins and I only turned on the ones I actually needed to have on.

    On 10/12, I turned this plugin back on but did not activate it. I didn't touch any other plugin or make any other changes (not on that day and not in the last 3 months -- just had a baby so I haven't been fussing with the site much).

    On 10/18, my host shut me down again, saying that I caused server overload -- 360,000 hits. Unfortunately, this wasn't a mention in the NYT or anything -- I suspect it was just this plugin. Again.

    As of 1 AM I've been unsuspended and have gone in and disabled the plugin -- and it seems to be working ok thus far... <fingers crossed>

    Anyone else have problems like this? Is it a setting that I screwed up with Super Cache, or should I just find another caching program? (Because I do need one, right?)

    TIA...

  2. Donncha O Caoimh
    Member
    Posted 2 years ago #

    Have you been able to look at the access logs? They should quite clearly show where 360,000 hits came from. I don't think it's Supercache unless preload caused it and there's a 1 second delay in between each request. That could not cause your server to be overloaded. The requests are serialized - they happen one after the other, not in parallel.

  3. velopeloton
    Member
    Posted 2 years ago #

    I have the same issue. If the plugin is activated the cpu usage goes through the roof.

  4. Donncha O Caoimh
    Member
    Posted 2 years ago #

    Tried the debug log in the plugin? That may shed some light on the issue.

  5. velopeloton
    Member
    Posted 2 years ago #

    Hi Donnacha

    I have it sorted. It was another plugin"Thumbs Excerpt" that was causing the problem. When I disabled Super Cache it worked and when I disable Thumbs it worked. The two would not run together. I deleted Thumbs and reinstalled it. That did the trick.

    Thanks
    Paddy

  6. katmmad
    Member
    Posted 2 years ago #

    As for me, I disabled the plugin but got shut down again -- after some investigation (the tip to look at my access logs was very helpful, thank you) I decided my blog had just grown too big for shared hosting. (Good problem to have, I guess!) So we moved to a dedicated server last night.

    I'll report back if any other plugin related problems, but thank you re: access logs and stuff. :)

Topic Closed

This topic has been closed to new replies.

About this Topic