WordPress.org

Ready to get started?Download WordPress

Forums

Super Slow Posting (8 posts)

  1. rawalex
    Member
    Posted 6 years ago #

    Using version 2.5.1

    Add a new post to a blow with 5000 posts. Click save. Go get coffee. Mow the lawn. Come back, maybe it is posted.

    What the heck is going on during the post routine that takes so long? It's chugging along and really slamming mysql as it goes.

  2. rawalex
    Member
    Posted 6 years ago #

    Bumping this up to the top. I can't understand why the simple concept of adding a post should run a (pretty powerful dedicated) server into the ground.

    I have found plenty of things that are checked and rechecked that aren't indexed... like wp_post post_parent.

    HELP! 2.5.x has turned into a major slowdown in life.

  3. haochi
    Member
    Posted 6 years ago #

    Have you added a lot of plugins to WordPress lately? (or any?)

  4. rawalex
    Member
    Posted 6 years ago #

    No, minimal plugins, nothing in the posting area (no tagging or other). This is a very clean and basic blog, just has a TON of posts.

    As a test, I duped the DB and removed about 25% of the posts. The adding of a new post was much faster. That tells me that some of the code in there is doing something the wrong way, because it doesn't scale right.

  5. iridiax
    Member
    Posted 6 years ago #

    What plugins are you using?

  6. rawalex
    Member
    Posted 6 years ago #

    google sitemaps, I have the latest version (updated 2 days ago, I think), which is slow but not the source of the issue.

  7. iridiax
    Member
    Posted 6 years ago #

    I have had problems with slow posting several times before. Here were the causes:

    • An overloaded server at my webhost
    • A bad plugin
    • One of the update services http://rpc.pingomatic.com in my "Writing Settings" being either down or slow
    • The "Attempt to notify any blogs linked to from the article (slows down posting.)" option in my "Discussion Settings"
  8. rawalex
    Member
    Posted 6 years ago #

    iridiax, the server is dedicated, and otherwise extremely fast. The blogs only ping the usual suspects. Removing 25% of the old posts from the blog suddenly made posting faster. The only plugin in use (outside of askimet) is the google sitemap, which is the latest version and takes about 15 seconds to run.

    Seems to be issues with poor indexing and way too much stuff being done during what should be a simple posting process.

Topic Closed

This topic has been closed to new replies.

About this Topic

Tags

No tags yet.