WordPress.org

Ready to get started?Download WordPress

Forums

Super Slow Load::Tried everything, no fix (24 posts)

  1. berserkerror08
    Member
    Posted 5 years ago #

    I run a wordpress site, http://www.newcovenantfl.org and the load time has been seriously increased with everything-- the pages and the admin dashboard. everything is updated, i deactivated all my plugins and tried the default themes, that brings it down by a few seconds but its still absurd wait time.

    please help! im gonna go nuts with this!

  2. iocchelli
    Member
    Posted 5 years ago #

    Do you have phpMyadmin access? If so, I'd start by doing an optimize and repair on the database.

    Other than that, it's difficult to know your problem based on the limited info. you've provided. Are you self-hosted? Shared hosting? If shared, it could be your host that is slow.

  3. berserkerror08
    Member
    Posted 5 years ago #

    host is good-- i put a test site up (not wordpress and can zip around fine) my gut told me it was the database but i dont know how to do an optimize and repair... my host gives me cpanel. should i look around for and optimize and repair option in the sql part?

  4. iocchelli
    Member
    Posted 5 years ago #

    cpanel usually comes with phpmyadmin. However, some versions of cpanel also have a databases icon. If you click on that, you will see a 'modify' section and the ability to select a database and repair it. Do you see either of those options (phpmyadmin or the database icon)?

  5. berserkerror08
    Member
    Posted 5 years ago #

    i see the phpmyadmin, i log in, i can get to the database, but i dont see a repair option anywhere. i just see a web interface for updating the tables in the database and stuff.

  6. berserkerror08
    Member
    Posted 5 years ago #

    wait-- found it. i went with repair and then optimize, but the load time is still terrible. :[ what now?

  7. iocchelli
    Member
    Posted 5 years ago #

    When you did the repair+optimize, were all the tables selected (checked off)?

    I'm uncertain what comes next. hmmm...

  8. berserkerror08
    Member
    Posted 5 years ago #

    im looking through these tables and i see a lot from old plugins.... maybe they were bad and didnt properly uninstall???

  9. iocchelli
    Member
    Posted 5 years ago #

    Most plugins that install tables don't remove the tables when you deactivate them. Those tables shouldn't hamper performance, but I could be wrong. You could remove them and see if it makes a difference.

  10. berserkerror08
    Member
    Posted 5 years ago #

    these are plugins i deleted... im going to try and reinstall and do a proper unistall from inside wordpress

  11. berserkerror08
    Member
    Posted 5 years ago #

    no effect :[

  12. iridiax
    Member
    Posted 5 years ago #

    host is good-- i put a test site up (not wordpress and can zip around fine)

    Is the test site also one that uses a database? My former webhost was fine with static html sites and a snail with ones that used a database.

  13. berserkerror08
    Member
    Posted 5 years ago #

    i used a website optimizer to give me some pointers: can anyone help discern this?

    Analysis and Recommendations

    * TOTAL_HTML - Congratulations, the total number of HTML files on this page (including the main HTML file) is 1 which most browsers can multithread. Minimizing HTTP requests is key for web site optimization. Y
    * TOTAL_OBJECTS - Warning! The total number of objects on this page is 34 which by their number will dominate web page delay. Consider reducing this to a more reasonable number. Above 20 objects per page the overhead from dealing with the actual objects (description time and wait time) accounts for more than 80% of whole page latency. See Figure II-3: Relative distribution of latency components showing that object overhead dominates web page latency in Website Optimization Secrets for more details on how object overhead dominates web page latency. Combine, refine, and optimize your external objects. Replace graphic rollovers with CSS rollovers to speed display and minimize HTTP requests. Consider using CSS sprites to help consolidate decorative images. Using CSS techniques such as colored backgrounds, borders, or spacing instead of graphic techniques can reduce HTTP requests. Replace graphic text headers with CSS text headers to further reduce HTTP requests. Finally, consider optimizing parallel downloads by using different hostnames or a CDN to reduce object overhead.
    * TOTAL_IMAGES - Warning! The total number of images on this page is 31 , consider reducing this to a more reasonable number. Recommend combining, replacing, and optimizing your graphics. Replace graphic rollover menus with CSS rollover menus to speed display and minimize HTTP requests. Consider using CSS sprites to help consolidate decorative images. Use CSS techniques such as colored backgrounds, borders, or spacing instead of graphic techniques to reduce HTTP requests. Replace graphic text headers with CSS text headers to further reduce HTTP requests. Finally, consider optimizing parallel downloads by using different hostnames to reduce object overhead.
    * TOTAL_CSS - Congratulations, the total number of external CSS files on this page is 2 . Because external CSS files must be in the HEAD of your HTML document, they must load first before any BODY content displays. Although they are cached, CSS files slow down the initial display of your page. Remember to place CSS files in the HEAD and JavaScript files at the end of the BODY to enable progressive display.
    * TOTAL_SIZE - Warning! The total size of this page is 233826 bytes, which will load in 53.40 seconds on a 56Kbps modem. Consider reducing total page size to less than 100K to achieve sub 20 second response times on 56K connections. Pages over 100K exceed most attention thresholds at 56Kbps, even with feedback. Consider optimizing your site with Website Optimization Secrets, Speed Up Your Site or contacting us about our optimization services.
    * HTML_SIZE - Congratulations, the total size of this HTML file is 9379 bytes, which less than 50K. Assuming that you specify the HEIGHT and WIDTH of your images, this size allows your HTML to display content in under 10 seconds, the average time users are willing to wait for a page to display without feedback.
    * IMAGES_SIZE - Warning! The total size of your images is 203061 bytes, which is over 100K. Consider switch graphic formats to achive smaller file sizes (from JPEG to PNG for example). Finally, substitute CSS techniques for graphics techniques to create colored borders, backgrounds, and spacing.
    * CSS_SIZE - Warning! The total size of your external CSS is 21386 bytes, which is over 20K. Consider optimizing your CSS for size by eliminating whitespace, using shorthand notation, and combining multiple CSS files where appropriate. By using labeled container cells and descendant selectors you can target chunks of HTML content efficiently without the need to embed extra claases and styles.
    * MULTIM_SIZE - Congratulations, the total size of all your external multimedia files is 0 bytes, which is less than 10K.

  14. iocchelli
    Member
    Posted 5 years ago #

    That definitely shouldn't be the issue. My site has way more going on than yours and it loads much faster. It seems to me that just *connecting* is taking the longest time. It makes me think there is a problem with your server, your nameserver/registrar, or maybe something in your htaccess file or firewall is slowing things down.

  15. iocchelli
    Member
    Posted 5 years ago #

    You must have done something - you are loading very quickly now!

  16. iocchelli
    Member
    Posted 5 years ago #

    And now you are slow again. If the site loads super quick one minute and super slow the next minute, I think it must be a server thing.

    I loaded your site a few times and it was super fast. Now it
    s really slow again. This is not WordPress - there is something else going on.

  17. salmanager
    Member
    Posted 5 years ago #

    What version of WordPress are you on? Did this start happening after you upgraded? Does it seem slow on some occasions, 60s+ and works normally other times? If you answered yes above you can read my previous post below:

    http://wordpress.org/support/topic/281079?replies=1

    I have found, for me at least database connection (timeout) problems after my upgrade to 2.8. I'm not saying that its 2.8 that's the issue, more likely a plugin I have conflicting with changes in the wp-db.php file in version 2.8 which handles the mysql connections. Everything works like a charm on 2.7.1

    for more visibility, you can install WP-TUNER plugin and do a show all. If you see that the "init" process is highlighted as slow or you see any "mysql server has gone away" errors, then let's talk further.

  18. berserkerror08
    Member
    Posted 5 years ago #

    well ive been using 2.8 from the start-- sometimes it loads just fine and others it can take as long as 25 seconds. ill try that plugin and get back to you-- thanks!

  19. berserkerror08
    Member
    Posted 5 years ago #

    "start" and "init" are highlighted. what do i do next??

    Index Marker %Time %DB Time %DB Count Time DB Time DB Count Memory Output
    (msec) (msec) (kb) lev(bytes)
    0 Start 78 67 29 7,221.4 7.6 2 ?
    1 plugins_loaded 1 16 29 105.3 1.8 2 ? 0()
    2 widgets_init 0 0 0 35.5 0.0 0 ? 0()
    3 init 19 6 14 1,745.3 0.7 1 ? 0()
    4 admin_init 0 6 14 42.6 0.7 1 ? 1(0)
    5 admin_head 0 0 0 41.1 0.0 0 ? 1(1781)
    6 admin_notices 0 5 14 39.7 0.6 1 ? 1(10622)
    7 admin_footer 0 0 0 0.1 0.0 0 ? 1(18870)
    8 Stop ? 1(18870)
    Total 100 100 100 9,231.1 11.4 7

  20. caddyx
    Member
    Posted 5 years ago #

    Did you get this issue resolved? I just started having the same problem and found out that when I remove the .htaccess file, everything loads quickly. But my permalinks don't work. I don't know anything about the .htaccess file. How could it be causing this problem?

  21. berserkerror08
    Member
    Posted 4 years ago #

    i havent gotten this resolved. where do i find the .htaccess file?

  22. atomgobbler
    Member
    Posted 4 years ago #

    I had the same issue. I think it was a combination of the server install with Fantastico, upgrading in WP admin panel and playing with different plug-ins. Even though I upgraded through wordpress admin my server was still not recognizing it and sending messages to upgrade...even though it was. So I tried upgrading through Fantastico and my problems worsened.

    I tried to fix the database, but the problem was deeper than I could fix. The site was built to blow up anyway, so I just reinstalled.

    If you guys figure out the issue be nice to know.

  23. rad_thundercat
    Member
    Posted 4 years ago #

    Same issue here.

    I was using 2.8 and upgraded to 2.9.1 and still have the problem.

    The site works fine, it's just on the back-end where it takes forever to load certain pages.

    For instance, I can click 'add new' (post) and the next page comes right up. However, if I click 'plugins' it takes over 60 seconds to load (I was getting FastCGI error 500 pages, but after bumping up the timeout to something ridiculous it works, just painfully slow)

    The only clue I've gotten so far is from using WPTuner. For the long loading clicks I get a yellow highlighted, "(marker)admin_init with a (%Time) of 99".

    So admin_init seems to be the culprit, but what is it? I'm going to keep searching, but I thought I'd post this up incase anyone can help.

    Thank you!

  24. rad_thundercat
    Member
    Posted 4 years ago #

    Hey all, this is what fixed it for me:

    Put an .htaccess file in the root directory of your WP install. Open the .htaccess and replace any code in it with this:

    <head>
    <meta http-equiv="Content-Type" content="text/html; charset=windows-1252">
    </head>
    
    # BEGIN WordPress
    
    # END WordPress

    Let me know if that helped!

Topic Closed

This topic has been closed to new replies.

About this Topic