WordPress.org

Ready to get started?Download WordPress

Forums

Super Cache Plugin Exclusion (7 posts)

  1. cq
    Member
    Posted 6 years ago #

    Donncha, thanks for a really wonderful caching system here. I really appreciate all your hard work on this and sharing with the wp community. The problem i'm having is that this affects, as i surmised, firestats. is there any way to exclude this plugin from the cache? not being able to see firestats update correctly may be a deal killer for me - i really don't want that b/se this caching system works very, very well.

  2. Samuel Wood (Otto)
    Tech Ninja
    Posted 6 years ago #

    On the super cache config page, you can exclude any specific URL from being cached by simply typing part of that URL into the exclusion box. I use that to exclude several different pages from caching.

  3. erick_paper
    Member
    Posted 6 years ago #

    Not sure what you guys are doing right and I'm doing wrong, but installing broke pretty much everything in my caching solution, which prior to installing SuperCache, was only WP-Cache! Now I've deactivated SuperCache and only have WP-Cache going, but that doesn't work either! Comes up with a blank page in its Options page.

  4. erick_paper
    Member
    Posted 6 years ago #

    Btw, SuperCache's recognition of my mod_rewrite was wrong. I have it enabled server wide. If SuperCache expects .htaccess to be writable, that's a pretty silly expectation. Maybe I'm spoilt by the easy functionality of WP plugins that "just work", but this was one painful beast.

  5. Samuel Wood (Otto)
    Tech Ninja
    Posted 6 years ago #

    WP-Cache and WP-SuperCache are not compatible. But, since WP-SuperCache has WP-Cache built into it, this doesn't much matter.

    Before installing the super cache, I highly recommend removing WP-Cache and everything associated with it. Make the site work normally, without wp-cache, before trying to install the super cache plugin.

  6. erick_paper
    Member
    Posted 6 years ago #

    Ok, I have disabled both plugins. Cleaned up the WP-Cache thing completely. The "Cache/meta" folder was giving permissions problems so I deleted it as root user. All htaccess files from strange folders are deleted.

    The site works fresh. Without caching. All links checked, from categories, to individual posts to indexes and RSS.

    Now I re-enable SuperCache and it doesn't work. Some of the links are not working either. I guess this has to do with the mod_rewrite rules that SuperCache is absolutely miserable with.

    My site structure:

    WP admin: http://domain.com/wpcms/wp-admin
    Blog: http://domain.com/site/

    In my root folder for the domain.com site, I have this .htaccess:

    # BEGIN WordPress
    <IfModule mod_rewrite.c>
    RewriteEngine On
    RewriteBase /site/
    RewriteCond %{QUERY_STRING} !.*s=.*
    RewriteCond %{HTTP_COOKIE} !^.*comment_author_.*$
    RewriteCond %{HTTP_COOKIE} !^.*wordpressuser.*$
    RewriteCond %{HTTP_COOKIE} !^.*wp-postpass_.*$
    RewriteCond %{HTTP:Accept-Encoding} gzip
    RewriteCond %{DOCUMENT_ROOT}/site/wp-content/cache/supercache/%{HTTP_HOST}/site/$1index.html.gz -f
    RewriteRule ^(.*) /site/wp-content/cache/supercache/%{HTTP_HOST}/site/$1index.html.gz [L]
    
    RewriteCond %{QUERY_STRING} !.*s=.*
    RewriteCond %{HTTP_COOKIE} !^.*comment_author_.*$
    RewriteCond %{HTTP_COOKIE} !^.*wordpressuser.*$
    RewriteCond %{HTTP_COOKIE} !^.*wp-postpass_.*$
    RewriteCond %{DOCUMENT_ROOT}/site/wp-content/cache/supercache/%{HTTP_HOST}/site/$1index.html -f
    RewriteRule ^(.*) /site/wp-content/cache/supercache/%{HTTP_HOST}/site/$1index.html [L]
    RewriteCond %{REQUEST_FILENAME} !-f
    RewriteCond %{REQUEST_FILENAME} !-d
    RewriteRule . /index.php [L]
    </IfModule>
    # END WordPress
    
    <IfModule mod_rewrite.c>
    RewriteEngine On
    RewriteBase /wpcms/
    RewriteCond %{REQUEST_FILENAME} !-f
    RewriteCond %{REQUEST_FILENAME} !-d
    RewriteRule . /wpcms/index.php [L]
    </IfModule>

    The WPCMS is working fine. I can admin.

    The main page on the SITE is working fine too. Index page, that is. But none of the individual posts and categories are working. What gives?

    I would like to do this with .htaccess in the main root folder, which should handle the rewrite rules just fine for all these folders. Because I will ultimately have about 15 blogs and I don't want a labyrinth of different unmaintainable .htaccess rules in different virtual folders.

    Thanks for any tips or advice!

  7. Samuel Wood (Otto)
    Tech Ninja
    Posted 6 years ago #

    It looks like the plugin is doing the rewrite rules incorrectly for your unusual configuration case. The wp-content folder is in the /wpcms directory, yes? So those rewrite rules should be
    RewriteCond %{DOCUMENT_ROOT}/wp-cms/wp-content...
    ...and similar.

    Also, if you're doing 15 different blogs on the same site, I'd use WordPress MU instead. More difficult to setup, but simpler once it's going for multi-blog cases.

Topic Closed

This topic has been closed to new replies.

About this Topic