WordPress.org

Ready to get started?Download WordPress

Forums

WP Super Cache
Super Cache not redirecting or caching urls w/o trailing slash (4 posts)

  1. IshenerZaph
    Member
    Posted 8 months ago #

    I just noticed Super Cache treats the url without the trailing slash differently. when i go to the url with the trailing slash all is fine. the caching works. but for urls without the slash it doesn't redirect nor caches.

    here is an example from my live site. this page is fine:
    http://www.honordiaries.com/wall-honor/

    but this page isn't:
    http://www.honordiaries.com/wall-honor

    http://wordpress.org/plugins/wp-super-cache/

  2. IshenerZaph
    Member
    Posted 8 months ago #

    Unfortunately, because of this issue I will be forced to change my caching plugin to W3TC

  3. katazina
    Member
    Posted 8 months ago #

    Hi,
    I don't want to defend the plugin it has issues I also reported one, but I think this is not it's fault. It's more likely the server settings what could redirect the not slashed url to the slashed one.

    The not caching part, if you see the code of the two different pages, what you linked, then you will see, that none of these are cached, so maybe the cache isn't configured right.

  4. Donncha O Caoimh
    Member
    Plugin Author

    Posted 8 months ago #

    IshenerZaph - you don't want two different URLs with the same content as it may cause problems for Google and other search engines. Pick the URL with the trailing slash, that's what WP usually uses and uninstall whatever you have that lets you use both URLs.

Reply

You must log in to post.

About this Plugin

About this Topic

Tags

No tags yet.