WordPress.org

Ready to get started?Download WordPress

Forums

Super Cache is enabled ? (10 posts)

  1. nokenny
    Member
    Posted 6 years ago #

    Hello ,

    my problem is the first time for each page and user the cache is dynamic generated then
    if i refresh is wp_cache served page, so each user refresh the cache on every session.

    I never see super_cache on source page too usualy one anonymous user have to refresh the cache every hour but on my blog is every session.

    u can see on this page http://www.nokenny.com/

    I hope u understand what i mean, sorry for my english.

    Thanks for u help

  2. Samuel Wood (Otto)
    Tech Ninja
    Posted 6 years ago #

    Yes, the wp-cache is user specific and the wp-super-cache is only good for non-logged-in users. That's normal.

    If you have lots of users who are always logged in, wp-super-cache won't be as effective for you. This is not the most common use case, however. You can extend the caching time, that will help somewhat.

  3. nokenny
    Member
    Posted 6 years ago #

    Yes i know this i try with one browser where i am logued and another one not logued and anyway i never have super_cache in source.

  4. nokenny
    Member
    Posted 6 years ago #

    "my problem is the first time for each page and user the cache is dynamic generated then
    if i refresh is wp_cache served page, so each user refresh the cache on every session."

    Now is look like ok for this but is not super_cache and wp_cache canot support 30k visits :/

    Now only donncha can save me :'((

  5. nokenny
    Member
    Posted 6 years ago #

  6. MoonbatWingnut
    Member
    Posted 6 years ago #

    Yes, the wp-cache is user specific and the wp-super-cache is only good for non-logged-in users. That's normal.

    Bummer. Is there a way to set it so anyone hitting the site gets a cached page within the time set that the page is cached? I'm not doing comments or logins, just want to serve mostly static pages.

    Thanks,

    TW

  7. Samuel Wood (Otto)
    Tech Ninja
    Posted 6 years ago #

    Bummer. Is there a way to set it so anyone hitting the site gets a cached page within the time set that the page is cached? I'm not doing comments or logins, just want to serve mostly static pages.

    No, you're not understanding. The pages are static either way, the difference is in how they are static.

    Normally, WordPress's pages show different things to logged in users. The comments form, for example, will often show the users name and not force him to type in his email address and such. You want each user to get his own pages correctly, which is why WP-Cache handles it. WP-Cache still uses static pages and does not hit the database, but it does run some PHP. This allows it to recognize the user cookie and serve the correct static page from the cache folder.

    Anonymous users, on the other hand, don't get any customizations. This is where the super cache kicks in. It redirects them to a static page without ever launching any PHP code. If you're not doing logins, then most users will see the Super-Cache page.

    Both ways are still "static" in that it never talks to the database (unless the static page hasn't been built yet or needs to be refreshed). Both give a major speed enhancement.

    If you want to make the caches last longer so that the refreshes don't happen as often, adjust the numbers for the two caches on the super cache configuration page. The default is to allow the WP-Cache to refresh after 1 hour and to allow the WP-Super-Cache to refresh after 6 hours.

  8. MoonbatWingnut
    Member
    Posted 6 years ago #

    Ah, okay, thank you for that explanation. You're right, I was not understanding. :-)

    I've just been through the rabbit hole of getting my domain away from Yahoo/Melbourne and waiting on the DNS to catch up, then I'll reactivate the plugin and try again. Also going into permissions settings and I can see I need to reset some of those to get this to install correctly. (Which is a long way of saying - I'll be back.)

    TW

  9. nokenny
    Member
    Posted 6 years ago #

    But anyway logued or not i never see <!-- super_cache --> and in admin i have 0 pages cached with supercache.
    Do you have any idea ? i try to re-install but is same.

  10. Donncha O Caoimh
    Member
    Posted 6 years ago #

    Open your wp-config.php and make sure the "define( 'WP_CACHE', true);" line is above the wp-settings.php include command.
    Is your cache directory writeable?
    Open up wp-content/advanced-cache.php and debug it. Add error_log() commands to figure out what the code is doing.

Topic Closed

This topic has been closed to new replies.

About this Topic