WordPress.org

Ready to get started?Download WordPress

Forums

WP Super Cache
[resolved] Super Cache causing RSS error (10 posts)

  1. GeekyJules
    Member
    Posted 9 months ago #

    I updated the Super Cache plugin yesterday.

    It broke my RSS feed.

    If I have Super Cache turned on, this is the error:

    This feed does not validate.

    line 3, column 82: XML parsing error: <unknown>:3:82: XML or text declaration not at start of entity [help]

    ... closing HTML tag. Check your theme. --><?xml version="1.0" encoding="UT ...
    ^
    Source: http://geekypleasures.com/feed/

    1.
    2. <!-- Page not cached by WP Super Cache. Blank Page. Check output buffer usage by plugins. -->
    3. <!-- Page not cached by WP Super Cache. No closing HTML tag. Check your theme. --><?xml version="1.0" encoding="UTF-8"?>

    But, as soon as turn caching off, it works fine.

    First, I tried to disable the plugin in, but for some reason, disabling the plugin never actually disabled it, and it continued to cache. Turning off caching in Super Cache's settings was the only way to get my feed working again.

    My only initial thought is that, for some reason, the plugin is adding a blank line at the top of the feed. With Super Cache off, the feed begins with:

    1. <?xml version="1.0" encoding="UTF-8"?>
    2. <rss version="2.0"

    Any fixes other than keeping this plugin off?

    http://wordpress.org/plugins/wp-super-cache/

  2. rommux
    Member
    Posted 8 months ago #

    to me the same problem

  3. GeekyJules
    Member
    Posted 8 months ago #

    When are you going to get this sorted? I was hoping the last update would do it. But, nope. It's still breaking the RSS feed.

  4. alexfads
    Member
    Posted 8 months ago #

    i have the same problem

  5. esmi
    Forum Moderator
    Posted 8 months ago #

    @alexfads: If you require assistance then, as per the Forum Welcome, please post your own topic.

  6. Donncha O Caoimh
    Member
    Plugin Author

    Posted 8 months ago #

    Go into the Debug tab of the plugin settings page and uncheck "Cache Status Messages". That will disable all messages in the footer.

  7. GeekyJules
    Member
    Posted 8 months ago #

    That worked. Thanks.

  8. alexfads
    Member
    Posted 8 months ago #

    I did this, but now even if i try and manually validate my feed by going to http://www.fredastairewisconsin.com/feed, now i get a 404...? Before I unchecked the cache status messages option, there was a big error screen in red, now its a blank 404...

  9. GeekyJules
    Member
    Posted 8 months ago #

    Alex, your feed is working for me. Maybe there was a slight hiccough with your hosting provider.

  10. rarylson
    Member
    Posted 5 months ago #

    WP Supercache sometimes conflites with some plugins/wp features when debug mode was enabled.

    It's a WP Supercache limitation: the WP Supercache debug mode doesn't work with feeds.

    Try to disable the WP SuperCache Debug. It worked for me.

    In wp-admin/options-general.php?page=wpsupercache&tab=debug, disable the Debugging enable checkbox.

Reply

You must log in to post.

About this Plugin

About this Topic