WordPress.org

Ready to get started?Download WordPress

Forums

Super Admin problem (10 posts)

  1. Isaak Wells
    Member
    Posted 4 years ago #

    right here is the deal,

    I successfully changed my table prefix and and all is well except one problem. I installed my new wordpress but when I migrated users and user meta I do not have Super Admin Control on any user because I did not set it up with my old prefix database.

    Now here is the question.
    Is there a way I can go into the sql file though phpmyadmin or something and give myself super admin access?

  2. Yep.

    Go inot phpmyadmin, find the sitemeta table and there will be a field there for siteadmins. Yes, it means Super admins now.

  3. Isaak Wells
    Member
    Posted 4 years ago #

    Thanks for the reply. Bare with me though because I am very new at the back end stuff.

    I found the table you are talking about. now what do i do?

  4. Isaak Wells
    Member
    Posted 4 years ago #

    Never mind I figured it out. Thanks so much for the help.

  5. satomom
    Member
    Posted 4 years ago #

    I noticed today that the "network" option under tools is gone. And I don't have super admin access anymore, though I do have admin access.

    Checked phpmyadmin and made sure my username was listed in site_admins in wp_sitemeta. It is, though I don't know what the other numbers and code in there means.

    Also checked to make sure the define('WP_ALLOW_MULTISITE', true); command was still in wp-config. It is.

    Also deactivated all plugins in unlikely event something there was the culprit. No change.

    I've done something awful, no doubt, but have no idea what and how to get network and my super admin privileges back!

    Can anyone help me?

  6. and made sure my username was listed in site_admins in wp_sitemeta. It is, though I don't know what the other numbers and code in there means.

    Paste it in here, and I'll tell ya.

  7. satomom
    Member
    Posted 4 years ago #

    Hi, Andrea -

    Here you go:

    a:1:{i:2;s:11:"username";} (where 'username' is my admin username)

    Any ideas?

  8. satomom
    Member
    Posted 4 years ago #

    I'm also noticing I can't add or change the status of users, like I typically could with regular admin privileges.

  9. satomom
    Member
    Posted 4 years ago #

  10. a:1:{i:2;s:11:"username";} (

    see the i:2 ? It shoudl be a 1 since there's only one username following. not two.

    and the s:11 - the 11 should be how many characters are in your username.

Topic Closed

This topic has been closed to new replies.

About this Topic