WordPress.org

Ready to get started?Download WordPress

Forums

[closed] Super admin not showing (48 posts)

  1. holmpage
    Member
    Posted 3 years ago #

    I'm doing a trial run of multisite on a HostGator account before setting up a new installation for a school. The school site is already using a subdomain, so I want the teachers' individual sites to be in subdirectories. I didn't see this option but achieved it in the config by setting subdomain_install to false. This is my second try; the first time I got the Super Admin option, but adding a site created a subdirectory, which surprised me as WordPress has been sitting on the domain for a year or so. So I started over, after deleting the extra tables in phpAdmin so that the installation wasn't telling me that it was already set up for a network.

    The problem may be in the username. From another topic here, I saw you ask if there were capital letters in the username. Somewhere along the way I changed "admin" to "Heather", and now there is no "admin".

    Can I add a super admin directly to the database? Or should I start over yet again?

    The site is at http://www.com-info.ca. I'm running it in French, but hopefully you can find your way around.

  2. Do you have the network enabled or not?

  3. holmpage
    Member
    Posted 3 years ago #

    Logged in as "heather" or "Heather", the only admin-level user, I do not see the "network" menu item that I saw before (I think that would be the right English term; in French it's "réseau") but at the top of the menu, under the dashboard button, I get "My sites" (mes sites), which suggests to me that the network is enabled but I'm not super admin anymore. Perhaps I had too many tabs open and didn't log out and in with the right sequence, or something like that.

    In phpMyAdmin I see tables for wp_blogs and wp_blog_versions.

    Under wp_user_capabilities, I am a:1:{s:13:"administrator";b:1;} and wp_user_level 10. If I change (one of) these, will it mess things up? What would I change them to exactly?

    (I suppose I should have done the trial run in English, but I need to learn the French vocabulary so I can teach the teachers to use it!)

  4. Ooo je suis une Canadien! ;)

    Usually just logging out shouldn't remove anything. Hrm.

    Okay, since you;re in the db anyway, look in the wp_sitemeta table. there's a meta key there called admin_user_id. Is it 1? Does that match the user ID of Heather?

  5. holmpage
    Member
    Posted 3 years ago #

    Vive les canadiennes !

    I don't see a wp_sitemeta table. In wp_options, admin_email is mine, in wp_users I have ID 1, in wp_usermeta I have user level 10. Those all pertain to the main blog, though, don't they? Nothing seems to be "meta" to that, except for wp_blogs and wp_blog_versions.

  6. Okay, so the tables for the network didn't get created.

    Did you follow the instructions and go through the menu to set up the network?
    http://codex.wordpress.org/Create_A_Network

    If so, make sure the db user has ALL permissions on the db.

  7. holmpage
    Member
    Posted 3 years ago #

    I think the permissions must be there because it worked the first time, except that subdomains showed up which I didn't want. Then I tried to erase all my steps, but it looks like I missed something so it didn't "take". I think I should start again from scratch. Restore the original config file, drop the extra tables, log out, log in a couple of times, make sure that it knows I really am admin - or need I go back to a fresh install of WordPress? Are there any other places where the network is "registered" (I'm comparing it to a registry entry on a computer)?

  8. jameshsi
    Member
    Posted 3 years ago #

    I install 3.01 today, and follow all the steps (http://codex.wordpress.org/Create_A_Network) exactly, I can not see the super admin menu too.

    I can see wp_usermeta and the rest network tables.

    I just don't understand why I can't see the super admin.

    Regards,

    James

  9. theandiamo
    Member
    Posted 3 years ago #

    I just created the network, and my WP installation says that it detects it when I click on the "network" link under tools. Didn't get any errors, All the plugins got reactivated just fine, I just don't see the "SuperAdmin" on my menu either. I'm hosting on hostgator too. Anyone know how to fix this?

  10. When you added the data to your wp-config.php file, you DID put it above the line that tells you to stop editing here, right?

  11. theandiamo
    Member
    Posted 3 years ago #

    In my case, yes. Right above it.

  12. holmpage
    Member
    Posted 3 years ago #

    Definitely, yes, in my case too.

  13. Everyone having issues with this, please look in your database and see if the extra tables were created.

  14. theandiamo
    Member
    Posted 3 years ago #

    can you maybe tell me what tables I should be looking for?

  15. wp_blogs
    wp_blog_versions
    wp_registration_log
    wp_signups
    wp_site
    wp_sitemeta

  16. theandiamo
    Member
    Posted 3 years ago #

    Yep, they're all there.

  17. T.McGuire
    Member
    Posted 3 years ago #

    I am seeing the same issue. I have followed all the steps and the tables have been created. I am using a fresh install of WP 3.0.1 and I do not see the Super Admin link.

    Update: I re-installed and used 'admin' as my first user admin name and it's working now. Hmm..

  18. When you added the data to your wp-config.php file, you put it above the line that tells you to stop editing here, right?

    Did you log off, flush your cookies, and log back on?

  19. Update: I re-installed and used 'admin' as my first user admin name and it's working now. Hmm..

    I've been able to set up the network using a username that was no admin.

    Was your with spaces?

  20. T.McGuire
    Member
    Posted 3 years ago #

    No spaces. And nothing else special. But for some reason it's working now. So I'm not going to mess with it.

  21. gigamorph
    Member
    Posted 3 years ago #

    I had the same problem but in my case while re-installing it with the admin login of "admin", I found that I had overwritten the line

    define('WP_ALLOW_MULTISITE', true);

    with

    define( 'MULTISITE', true );

    somehow thinking they were duplicates.

    Now with both lines in wp-config and my original non-"admin" username I see the super admin panel.

  22. theandiamo
    Member
    Posted 3 years ago #

    Ok, I'm confused now. Do I have to create a username "admin" before the super admin works? What exactly do I need to do now to get this working. Right now, I have one userid, "andiamo".

  23. theandiamo
    Member
    Posted 3 years ago #

    Woohoo! I had the same problem, the

    define( 'MULTISITE', true );

    was missing on my config file. Put it back in, logged out, logged back in and now I have the Super Admin menu! Thanks for all the help guys! :)

  24. holmpage
    Member
    Posted 3 years ago #

    I just changed my username to admin directly in the database, dropped the 2 out of 6 extra tables I had obtained, logged out and in, restored the original config file and .htaccess file and started over, following the directions. Now I have the Super Admin button AND all the new tables in the database.

    And I'm a little more adept with all this, which is what I really wanted.

    So despite WP's efforts to allow people use a name other than "admin" for security reasons, there are times when it might work better, depending on still unknown factors.

    Thanks for being there, especially Andrea_r. See you again, I'm sure.

  25. tristanmin
    Member
    Posted 3 years ago #

    @holmpage

    Yes! It's work for me too.
    I've just changed the user_login, user_nickname and display_name to "admin" in wp_users table.

    Thanks!

  26. I've had no issues setting it up under a different username. Dunno what's up.

  27. holmpage
    Member
    Posted 3 years ago #

    Could it depend on the host? DB permissions on some subtle level? ...

  28. jameshsi
    Member
    Posted 3 years ago #

    it seems define('WP_ALLOW_MULTISITE', true);
    and
    define( 'MULTISITE', true );
    are really confuse people when installing, pls someone edit the installation guide.

  29. waltspence
    Member
    Posted 3 years ago #

    Ok guys if you're still having issues. If this is a previous install of wordpress single user, then make sure you've deactivated all your plugins. After you have done this, go under Tools>Network and follow the installation from there.

  30. @jameshsi feel free! not sure how to make it any more clear that those are two different lines.

    I already edited that part about NOT removing the one originally put in to make the network menu show.

Topic Closed

This topic has been closed to new replies.

About this Topic