WordPress.org

Ready to get started?Download WordPress

Forums

[resolved] Super Admin missing in 3.1 (16 posts)

  1. summerchilde
    Member
    Posted 3 years ago #

    I've just upgraded to 3.1 and now there is no Super Admin menu link(s) anywhere in the dashboard. The only way I can get to the Super Admin is to click on "updates" in the new Admin bar. This is no good. I disabled all plugins and switched to twentyten to see if that would help. No go. What gives?

    Also, do not want the admin bar to show up on the front end of any of my sites. Can it be turned off with one click?

  2. Kim Parsell
    Volunteer Moderator
    Posted 3 years ago #

    Look in the upper right - there is now a link called Network Admin. That's where you go now to manage all network-related stuff.

    Here's how to turn off the admin bar:

    Disable Admin Bar and Hide Preferences:
    http://developersmind.com/2011/02/23/disable-admin-bar-and-hide-preferences/

  3. It's Network Admin now.

    Look on the top (grey) bar. On the far right it should say 'Network Admin'

    http://wpmututorials.com/news/new-features/network-admin/

    As for killing the admin bar, put this plugin in mu-plugins: http://wordpress.org/extend/plugins/disable-admin-bar/

  4. Jeremy Ashburn
    Member
    Posted 3 years ago #

    What do you if you don't have the Network Admin button on the far right? I've played around in these forums for about 30 minutes and cannot find any help! After upgrade I now have no Networking admin button on my admin bar. Agggh!

  5. summerchilde
    Member
    Posted 3 years ago #

    Going to mark this as resolved. Turns out I was having a plugin conflict that just wasn't noticeable. Custom Admin Branding plugin will hide that Network Admin link in the dashboard. I had no idea that link was there so didn't think to look.

    Thanks for the help guys.

    I also found the solution for removing the admin bar without a plugin. Add this to your theme functions.php:

    /* Disable the Admin Bar. */
    add_filter( 'show_admin_bar', '__return_false' );

    /* Remove the Admin Bar preference in user profile */
    remove_action( 'personal_options', '_admin_bar_preferences' );

  6. @Jeremy it;s not a button, it;s LINK.

    Also, get the Snack Bar plugin for the admin bar- it has EXTRA network featueres and makes things waaaaayyyyy easier to manage.

    And you know you can show the admin bar only when you are logged in.

  7. dpalmer
    Member
    Posted 3 years ago #

    I'm having this same issue.
    There is no network admin link/button, anything, anywhere on the site in 3.1.
    I have disabled all the plugins.
    I've tried numerous themes.

    Nothing is working. ????

  8. @mercime
    Volunteer Moderator
    Posted 3 years ago #

    There is no network admin link/button, anything, anywhere on the site in 3.1.

    You need to create a network first before you see any Network Admin link.

  9. Jeremy Ashburn
    Member
    Posted 3 years ago #

    I already have a network with 10 blogs. The issue is that the Network button is missing. I can get there by typing http://www.mysite.com/wp-admin/network/ but it's a little annoying. Any chance you could add the Network button to the right hand corner? I can show you a video if you want.

  10. You're looking in the right place? It IS there on all my sites.

    http://wpmututorials.com/news/new-features/network-admin/

  11. Any chance you could add the Network button to the right hand corner?

    It's there on all my installs.

    Have you tried disabling plugins to see if they are preventing it from showing?

  12. raskull
    Member
    Posted 2 years ago #

    I found the Network Admin link that went missing when I updated! Look in the upper right. It says "Howdy, [yourname]" with a little arrow next to it. Click on that and a menu of links appears: Your Profile, Network Admin, and Log Out. (I had to do a view source to discover this!) Not sure why they rolled this up, since there's plenty of room to run it horizontally in the bar...

  13. Get the snack bar plugin for network usage. way handy.

    http://wordpress.org/extend/plugins/snack-bar/

  14. pbel
    Member
    Posted 2 years ago #

    place the text that you should insert according to the network setup page on top of wp-config.php. That solved the missing link in my case.

    Cheers
    Petr

  15. belladotka
    Member
    Posted 2 years ago #

    I found the Network Admin link that went missing when I updated! Look in the upper right. It says "Howdy, [yourname]" with a little arrow next to it. Click on that and a menu of links appears: Your Profile, Network Admin, and Log Out. (I had to do a view source to discover this!) Not sure why they rolled this up, since there's plenty of room to run it horizontally in the bar...

    Thanks raskull, that help me a lot...it is a same issue with WordPress 3.21..and the same answer that you gave. It saved me a ton of time..:)

  16. Be aware, it'll move again in 3.3 to the admin bar.

Topic Closed

This topic has been closed to new replies.

About this Topic