WordPress.org

Ready to get started?Download WordPress

Forums

NextGEN Gallery
suhosin alert - unallowed setting of memory_limit (4 posts)

  1. SupuS
    Member
    Posted 10 months ago #

    Hello,

    there is problem with setting of memory_limit. This is the error message which I get :

    suhosin[29673]: ALERT - script tried to disable memory_limit by setting it to a negative value -1 bytes which is not allowed (attacker '*.*.*.*', file '/var/www/path/to/web/wp-content/plugins/nextgen-gallery/products/photocrati_nextgen/modules/attach_to_post/mixin.attach_to_post_display_tab.php', line 95)

    This setting in wp-config.php should be respected:

    define('WP_MEMORY_LIMIT', '60M');
    define('WP_MAX_MEMORY_LIMIT', '60M');

    http://wordpress.org/plugins/nextgen-gallery/

  2. DoubleSixx
    Member
    Posted 10 months ago #

    You can bump that up to 128M, and if you're on a Linux server check your root directory for a php.ini or php5.ini file.

    You can alter the following to match :

    memory = 192M
    memory_limit = 256M

    Improves nggallery uploading.

  3. SupuS
    Member
    Posted 9 months ago #

    Hello DoubleSixx,

    I know how to increase memory limit. Problem is in file:

    mixin.attach_to_post_display_tab.php

    where is:

    @ini_set('memory_limit', -1);

    on line 95. This directive cause blocking by suhosin. If suhosin is installed on server than you will have problems until you comment out this line. It doesn't matter what you set in php.ini.

    So I suggest remove this line and respect setting in wp-config.php or global setting in php.ini.

  4. DoubleSixx
    Member
    Posted 9 months ago #

    Sorry I couldn't help better, I'm not running suhosin.

Reply

You must log in to post.

About this Plugin

About this Topic