WordPress.org

Ready to get started?Download WordPress

Forums

Suggestion: Restrict Site Address (URL) to not allow return characters (1 post)

  1. trishahdee
    Member
    Posted 1 year ago #

    Background
    I install WP in its own directory then, when I'm ready to take the site live, I move the index and change the .htaccess and the settings > General > Site Address (URL) to reflect the root domain.

    In one such site, after I took it live, in Safari browser only, there was an odd character being added only to the main menu urls which caused the urls to go to the 404 page. I started two support threads on WordPress.org but it was the troubleshooting instructions from the Time.ly plugin support forum which eventually lead me to the true culprit...

    The Problem Found
    Apparently, when I took the site in question live, instead of deleting the folder name in the Site Address (URL) I must have hit the enter/return key. This did remove the directory name but added that pesky return which I could not see as the input is only one line in height. I checked this setting multiple times for characters after the url and as there was nothing and it looked right I didn't look closer. Eventually I found the error by searching the database and looking into the individual field entries.

    I'm sure I'm not the first person to do this, but it may be rare and therefore not of great urgency for repair... However, it would be good if the settings > general > WordPress Address (URL) and > Site Address (URL) were restricted so not to allow returns.

    For reference:
    http://wordpress.org/support/topic/line-feed-special-charater-only-in-safari-browser-urls?replies=1#post-4068087
    http://wordpress.org/support/topic/could-this-be-a-problem-with-the-calendar-update?replies=8#post-4163787

Topic Closed

This topic has been closed to new replies.

About this Topic